Jump to content

LaunchPad + CCSV5.2 + OpenSuSe 12.2

Recommended Posts

hi guys,


i am new here.


i am  a linux user, so i have my inhibitions of going back to windows just so that this kit could work as i beleive it is very much possible in windows too.


so the thing is..


i used CCSv5.2 to make a blinking LED Project and used the 'debug' option to get the code into the device.


my device is msp430 Launchpad.


the error message is  as folows.




Error initializing emulator:
No USB FET was found




to look into things i disconnected the Launchpad from the USB and reconnected it.

the kernel message log gave the following message.




[ 3077.760134] usb 3-4: new full-speed USB device number 3 using xhci_hcd
[ 3077.796775] usb 3-4: New USB device found, idVendor=0451, idProduct=f432
[ 3077.796783] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3077.796788] usb 3-4: Product: Texas Instruments MSP-FET430UIF
[ 3077.796792] usb 3-4: Manufacturer: Texas Instruments
[ 3077.796795] usb 3-4: SerialNumber: 2EFF426C50144B46
[ 3077.797050] usb 3-4: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[ 3077.802856] cdc_acm 3-4:1.0: This device cannot do calls on its own. It is not a modem.
[ 3077.802865] cdc_acm 3-4:1.0: No union descriptor, testing for castrated device
[ 3077.802891] cdc_acm 3-4:1.0: ttyACM0: USB ACM device
[ 3087.862748] hid-generic 0003:0451:F432.0003: usb_submit_urb(ctrl) failed: -1
[ 3087.862790] hid-generic 0003:0451:F432.0003: timeout initializing reports
[ 3087.863722] hid-generic 0003:0451:F432.0003: hiddev0,hidraw0: USB HID v1.01 Device [Texas Instruments Texas Instruments MSP-FET430UIF] on usb-0000:00:14.0-4/input1




and when i run the lsusb command.




Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 003: ID 0451:f432 Texas Instruments, Inc. eZ430 Development Tool
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 15d9:0a4f Trust International B.V.
Bus 001 Device 003: ID 8087:07da Intel Corp.
Bus 001 Device 004: ID 147e:1002 Upek
Bus 002 Device 003: ID 05ca:1823 Ricoh Co., Ltd



is the msp430 Launchpad an ez430 development tool?

i didnt knw that....


also... if it shows it as a device.. why cant i connect to it..

anybody has any idea...


if any more data is needed, i am happy to provide that too...


Link to post
Share on other sites

The current and older launchpad devices revision 1.5 and below will never work with CCS on linux. You can find an official statement on the e2e.ti.com forums.  The only debuggers that are supported are the $175 "real" MSP-FET430  devices. The only thing you can do with CCS and the launchpad on linux is use it to compile your code and use mspdebug to upload the 'foo.out' it creates. 

Link to post
Share on other sites

Look in the Debug or Release directory depending on which you are building. Assuming your project is called blink the elf file produced will be called 'blink.out


Download and compile the latest mspdebug.


add a /etc/udev/ entry for your launchpad or run mspdebug as root


$ mspdebug rf2500 "prog /home/arun/blink_ws/blink/Debug/blink.out"


Adjust the paths and file names to suit what you have used.



Link to post
Share on other sites

i tried building it but the compilation stops at an error.. both for the atest version and the earlier vesion



In file included from util/usbutil.c:22:0:
util/usbutil.h:22:17: fatal error: usb.h: No such file or directorycc  -DUSE_READLINE  -O1 -Wall -Wno-char-subscripts -ggdb -I. -Isimio -Iformats -Itransport -Idrivers -Iutil -Iui -DLIB_DIR=\"/usr/local/lib/\"  -o util/output.o -c util/output.c


The file "usb.h" was missing in the package itself... are there some dependencies that i am missing...

usb.h is a clue for me but i dont know what package to install

Link to post
Share on other sites

The mspdebug that comes with your package manager would probably work.  However, if possible I like to use the most recent up to date version of mspdebug. Daniel Beer, the mspdebug author, does an amazing job of addressing issues and constantly updating the code.    The linux distros can't keep up with his fast pace.


Hats off to Daniel!



Link to post
Share on other sites

well this did not work... "libusb" provides only "libusb.h" not usb.h,  i even tried "libhid-dev" based on some inputs from other forums but still no progress.


Sorry for the wrong package name, you need libusb-compat-devel instead.


I just tried it on a opensuse 12.1 vm.

linux-9w82:/usr/local/src/mspdebug-0.22 #
cc -s  -o mspdebug util/btree.o util/expr.o util/list.o util/sockets.o util/sport.o util/usbutil.o util/util.o util/vector.o util/output.o util/output_util.o util/opdb.o util/prog.o util/stab.o util/dis.o util/gdb_proto.o util/dynload.o util/demangle.o util/powerbuf.o util/ctrlc.o transport/cp210x.o transport/cdc_acm.o transport/ftdi.o transport/rf2500.o transport/ti3410.o transport/comport.o drivers/device.o drivers/bsl.o drivers/fet.o drivers/fet_core.o drivers/fet_proto.o drivers/fet_error.o drivers/fet_db.o drivers/flash_bsl.o drivers/gdbc.o drivers/sim.o drivers/tilib.o drivers/goodfet.o drivers/obl.o drivers/devicelist.o drivers/fet_olimex_db.o drivers/jtdev.o drivers/jtaglib.o drivers/pif.o formats/binfile.o formats/coff.o formats/elf32.o formats/ihex.o formats/symmap.o formats/srec.o formats/titext.o simio/simio.o simio/simio_tracer.o simio/simio_timer.o simio/simio_wdt.o simio/simio_hwmult.o simio/simio_gpio.o simio/simio_console.o ui/gdb.o ui/rtools.o ui/sym.o ui/devcmd.o ui/flatfile.o ui/reader.o ui/cmddb.o ui/stdcmd.o ui/aliasdb.o ui/power.o ui/input.o ui/input_console.o ui/input_async.o ui/main.o -lusb -lreadline -lpthread -ldl
linux-9w82:/usr/local/src/mspdebug-0.22 #

linux-9w82:/usr # find . -name usb.h
linux-9w82:/usr #
Link to post
Share on other sites
  • 1 year later...

Just for reference, I have the same error with make mspdebug 0.22 in Ubuntu 14.04:

In file included from util/usbutil.c:22:0:
util/usbutil.h:22:17: fatal error: usb.h: No such file or directory


I've installed libusb-dev (which is not the same than libusb-1.0.0-dev!!!) and problem solved :smile:


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...