Jump to content
Sign in to follow this  
MWE

MSPDebug rf2500: failed to open RF2500 device error Launchpad

Recommended Posts

When I run mspdebug from the command line I get this failure:
____
Microsoft Windows [Version 6.0.6002]
Copyright © 2006 Microsoft Corporation.  All rights reserved.

C:\Users\Mark>mspdebug
You need to specify a driver. Try --help for a list.

C:\Users\Mark>mspdebug rf2500
MSPDebug version 0.20 - debugging tool for MSP430 MCUs
Copyright © 2009-2012 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

rf2500: failed to open RF2500 device.
____
But mspdebug can see the Launchpad:
_______
C:\Users\Mark>mspdebug --usb-list
Devices on bus 000:
    000:000 0451:f432 eZ430-RF2500 [serial: 56FF42047150410A]

C:\Users\Mark>
___________________________
Running testlibusb-win.exe gives me this:
___________
DLL version:    1.2.6.0
Driver version:    1.2.6.0

bus/device  idVendor/idProduct
bus-0/\\.\libusb0-0001--0x0451-0xf432     0451/F432
- Manufacturer : Texas Instruments
- Product      : MSP430 Application UART
- Serial Number: 56FF42047150410A
bLength:             18
bDescriptorType:     01h
bcdUSB:              0110h
bDeviceClass:        00h
bDeviceSubClass:     00h
bDeviceProtocol:     00h
bMaxPacketSize0:     08h
idVendor:            0451h
idProduct:           F432h
bcdDevice:           0100h
iManufacturer:       1
iProduct:            5
iSerialNumber:       3
bNumConfigurations:  1
  wTotalLength:         53
  bNumInterfaces:       1
  bConfigurationValue:  1
  iConfiguration:       0
  bmAttributes:         80h
  MaxPower:             50
    bInterfaceNumber:   0
    bAlternateSetting:  0
    bNumEndpoints:      3
    bInterfaceClass:    2
    bInterfaceSubClass: 2
    bInterfaceProtocol: 1
    iInterface:         5
      bEndpointAddress: 82h
      bmAttributes:     03h
      wMaxPacketSize:   64
      bInterval:        255
      bRefresh:         0
      bSynchAddress:    0
      bEndpointAddress: 03h
      bmAttributes:     02h
      wMaxPacketSize:   64
      bInterval:        255
      bRefresh:         0
      bSynchAddress:    0
      bEndpointAddress: 83h
      bmAttributes:     02h
      wMaxPacketSize:   64
      bInterval:        255
      bRefresh:         0
      bSynchAddress:    0
______________
So it looks like libusb-win32 is installed right. It also looks right in Device Manager.
This is on Vista64. The Launch pad has the 2553 installed but I backed up to the original chip that I had used under gdb in a previous msp430 tool chain I know worked, same error.
The mspdebug I am using is from the pre compiled MSP chain XPG provides, just to limit the variables. I have tried forcing the serial number but that made no difference. Do I need another version of mspdebug than the current (0.20?) that's in the provided chain?
Any ideas on what to do next?
If there are any logs that would be useful in figuring this out just ask.
After going back over the install several times and reading posts till my eyes are blurry I am still stumped.

Help!

Mark

Share this post


Link to post
Share on other sites

Try "tilib" driver for mspdebug under Windows:

$ mspdebug tilib 

And example how to flash firmware:

$ mspdebug tilib --force-reset "prog /path/to/your/firmware.hex"

Share this post


Link to post
Share on other sites

Anyone with the solution to this issue, perhaps?

Windows7/64, supposedly all drivers installed (COM3 for the MSP USB UART here), mspdebug sees the device, but just can't open it. Everything like MWE said.

(The suggestion from ikravets results in "This driver does not support raw USB access.")

 

UPDATE (SOLVED!):

 

In the libusb driver package (mine is the SysProgs version), do run inf-wizard.exe to generate the correct .inf for the actual MSP430 debug interface. Then you just install it (can be done right from inf-wizard), and the device finally appears (under "libusb- win32 devices" under Device Manager), and mspdebug can access it, at last!
 
Hallelujah! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×