Jump to content

[Solved] Serial not working despite changing the jumpers

Recommended Posts

What a PITA. Hamada got it... I'll explain again with step-by-step for anyone else having issues


1) Program the board. There's nothing special about it

2) Unplug the board

3) Press and hold the reset button

4) Plug it back in [to your computer]

5) Wait three years (in reality, a few seconds... but it feels like an eternity)

6) Start your serial terminal on your computer (Putty, minicom, picocom, etc)

7) Wait three more years

8) Release the reset button


If it doesn't work, hold the button down longer. I tried it three times in a row holding down for 15-30 seconds and it didn't fail any of those three times.


Very annoying... but at least I have it working. Still a cool board for $4.30 though :D

Link to post
Share on other sites
  • 4 weeks later...

I have the same problem. I open the serial window or putty and notigh is being received...


To program i need like 10 tries to program it once. And then the serial never works!

This hapened before then it stopped for no reason...now it's back 


Serialprint has been so unreliable...

it was working yesterday. Today i tried it again and it doesnt not work...same code, didnt upload and notigh

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...