Jump to content

Switching Power Supply using a TPS61221

Recommended Posts

Soldered up another one of the boards and still seeing the same weird behavior. One thing I noticed is if I start without the resistor load and then add it, things seem to behave as expected. Really odd behavior all around. I've included the super simple schematic I had built, maybe someone can spot something stupid I'm missing, but otherwise I'm out of ideas.


Link to post
Share on other sites

That's pretty much what I got in a nutshell.  The components look familiar...... just remembered I shared my diptrace stuff with you :smile:  Haha.


Anyway yeah, the only difference in my design is I have a 1uF and 22uF ceramic cap on the VOUT/Feedback net.  No idea if that matters at all, I wouldn't think so.  10uF on the input side.  But then I never did experiment with mine quite like you are... I just tried CR2032 batteries and AA's to validate and didn't even watch the output voltage all that closely.


Lastly- The input cap is pretty close to the inductor, right?  It should all be pretty close anyhow but I don't know how your board is laid out.  Is it a home-etched PCB?  Mine is home-etched with everything SMD and very close together as the datasheet recommends (doesn't look identical but reasonably similar distances between parts).

Link to post
Share on other sites

The board is super tiny, everything is close to everything else.


Just tried out an experiment, I rigger up a 22uH PTH and everything is working much better. As long as the startup voltage is >= 2.0 it output 3.3 with the load. Without the load it can startup at ~1.1V.


So either my other inductors were too small or their current rating was too low. Will try some more PTHs to see what happens...



Link to post
Share on other sites

And there we go, just tried a 4.7uH PTH from my parts drawer and it starts up properly with the load as low as 1.0V. So seems to me that even the 600mA 4.7uH SMDs just wasn't enough. Time to go back to digikey and see if I can find something that can handle even more current, though I'm pretty sure that means going up in package size.

Link to post
Share on other sites

Definitely at a loss to explain that one.  Studied the datasheet again, they make no bones that your inductor shouldn't have to be rated more than like 200mA or so although the switching current mentions 400mA in the specs.  Wonder if the Taiyo Yuden inductor just sucks (poor quality?)


Just found out what I'm using-


Murata LQH32CN4R7M33L (link: http://www.mouser.com/ProductDetail/Murata/LQH32CN4R7M33L/?qs=%2fha2pyFadug6QTM2oSMsOA%2fjJnGFvlNG7cmlu3bVe9DJM2yI%252bK9NvQ%3d%3d )

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...