Jump to content
Sign in to follow this  
butterfingers

Mac to LaunchPad transfers - options? More TI support?

Recommended Posts

So, I'm at the end of dependency hell[1] and have the gcc tools successfully building elf firmware on my Mac. Yay. I also have MSPDebug installed and working. Double yay. Unfortunately, I'm kind of stuck when it comes to getting the elf to my LaunchPad. I tried to install the kernel[2] extension as noted in the MSPDebug FAQ, but borked my Mac totally to the point that I needed to go back to the metal and rebuild it from my Time Machine backup. At least I proved that I can restore my Mac if necessary!

 

Question, and yes, I know it's a bit controversial - how does Arduino do this so painlessly? If TI do want more hobbyists on MSP430, and that would appear to be the plan given the low pricing, then a little less pain will be necessary. Does anyone know if there are any plans to be a bit more inclusive?

 

[1] Dependency hell. Install msp430-gcc, you need magic binary A. To install A, you need B. To install B, you need script C. And so on, and so forth, until you're basically sat in front of a big black monolith wondering what the bone is for.

[2] If any tool installation starts to drift towards kernel speak just run, don't walk away, lest you end up like Hudson in Aliens after the dropship crash, picking up smoking bits of metal and saying, "we're in some real pretty sh-t now, man! Now what are we gonna do?"

Share this post


Link to post
Share on other sites

Finally!! I know not why though. :?

 

iMac:temperature-demo test$ mspdebug rf2500 'prog main.elf'

MSPDebug version 0.14 - debugging tool for MSP430 MCUs

Copyright © 2009-2011 Daniel Beer

This is free software; see the source for copying conditions. There is NO

warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

 

Trying to open interface 1 on 002

Initializing FET...

FET protocol version is 30001000

Configured for Spy-Bi-Wire

Set Vcc: 3000 mV

fet: FET returned error code 4 (Could not find device (or device not supported))

fet: command C_IDENT1 failed

fet: identify failed

Trying again...

Initializing FET...

FET protocol version is 30001000

Configured for Spy-Bi-Wire

Sending reset...

Set Vcc: 3000 mV

Device ID: 0xf201

Device: MSP430G2231

Code memory starts at 0xf800

Number of breakpoints: 1

Erasing...

Programming...

Writing 128 bytes to f800...

Writing 128 bytes to f880...

Writing 128 bytes to f900...

Writing 128 bytes to f980...

Writing 128 bytes to fa00...

Writing 128 bytes to fa80...

Writing 128 bytes to fb00...

Writing 128 bytes to fb80...

Writing 128 bytes to fc00...

Writing 76 bytes to fc80...

Writing 32 bytes to ffe0...

iMac:temperature-demo test$

 

OK, so it definitely worked, but now I'm worried about that error code 4...

Share this post


Link to post
Share on other sites
Did your program run? Maybe someone else can dump their console here. I doubt TI will support mac until there is alot of demand - that's my view from the e2e forums.

 

Yes, it seems to run OK. I think the error is because the LaunchPad is similar to, but not exactly the same as, the rf2500. This is about as small and simple as code can be, so I'll have to hope that it'll keep working if I do something more complex.

 

Old stats on the Arduino site, for example, show that just over a quarter of visitors are using Macs. If you infer that they're developing on the same OS as they visit on, then that's a lot of untapped audience for TI to target. What I'll try to do next is get msp430-gcc and mspdebug working cleanly with XCode, then write up a howto.

Share this post


Link to post
Share on other sites
how does Arduino do this so painlessly?

Arduino relies on a bootloader, so that the host systems only need to talk to "serial" ports.

Arduino uses (used?) a USB/Serial converter with well-established and well-proven multi-platform driver support. (The new "Uno" uses a different chip with theoretically wider (standardized) implementation, but less in that "well established and proven" department.)

Arduino uses a CPU whose gcc implementation was already "mature" (and "packaged") on multiple platforms.

Arduino's environment (eg "Processing") was envisioned as multi-platform (and even somewhat Mac-specific) from the ground up. It wasn't a matter of taking a windows or unix-specific tool and trying to make it multi-platform.

 

All IMO, of course.

 

(oh. Arduino isn't really as painless as it looks. In true chicken-and-egg fashion, there are a LOT of people poking away at Arduino, and when it breaks it gets fixed...)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...