Jump to content
43oh

fatal error


Recommended Posts

Hello guys,

 

I have occur a fatal error after i download and debug.

In the log it appear:

 

Mon Feb 14 04:26:18 2011: Interface dll version 2.4.7.1

Mon Feb 14 04:26:18 2011: Device : MSP430F2274

Mon Feb 14 04:26:18 2011: External voltage : 0.0 V

Mon Feb 14 04:26:18 2011: VCC voltage : 3.5 V

Mon Feb 14 04:26:18 2011: Invalid parameter(s)

Mon Feb 14 04:26:18 2011: Invalid parameter(s)

Mon Feb 14 04:26:25 2011: Verify error at address 0xffe7 on target 0x83 in file 0x9d

Mon Feb 14 04:26:25 2011: Verify error at address 0xffe6 on target 0xe in file 0x94

Mon Feb 14 04:26:28 2011: Verify error at address 0xFFE7. Value should be 0x9D but is 0x83.

Mon Feb 14 04:26:28 2011: Verify error at address 0xFFE6. Value should be 0x94 but is 0x0E.

Mon Feb 14 04:26:29 2011: Failed to load debugee: C:\........................

 

It seem that i have no problem compiling.

Link to post
Share on other sites

The compiler and linker are pure software inside your PC. They have nothing to do with the MSP430 chip nor the FET hardware tools.

 

When you want to "download" the object to the MSP430 via the FET, you got those errors because the drivers and dlls for these hardware are not set up correctly, not connected correctly, or not working correctly.

Link to post
Share on other sites

bumblebee,

 

I am having a hard time understanding your problem. Can you answer the following questions?

 

1. What compiler are you using? (Code Composer Studio/MSPGCC/Keil/IAR/Rowley/etc)

2. What operating system are you on? (Mac/Linux/XP/Win7/etc)

3. What development board are you using? (LaunchPad/Olimex/Soldercore/YourOwn/etc)

4. What does your code look like? (cut and paste your stuff between the code tags)

5. What function do you want your code to perform?

 

While some of us are quite intuitive, we are not mind readers so please add any other details that you think are significant.

 

And don't worry if English is not your first language. Most of us Engineers have been accused of being from another planet! ;)

Link to post
Share on other sites

Just for fun, I AM going to take a stab in the dark and say that you are using one type of MSP430 and your compiler is set up for a completely different MSP430.

 

For example, you are using an msp430g2231 but the project is configured to produce code for the msp430f5438a. This will produce all kind of errors when you try to debug the code.

 

What do you think?

Link to post
Share on other sites

@ OCY - Yes it can be debugged successfully

 

@ zeke -

1 . IAR

2. Win 7

3. LaunchPad

4. P1OUT = Bit1;

5. I want it to go into port 2 ISR but it seem when ever i add port 2 ISR it has this fatal error

 

Mine is MSP430F2274. and i have defined it too

 

it appeared: Warning[w52]: More than one definition for the byte at address 0xffe6 in common segment INTVEC. It is defined in module "mrfi" as well as in module

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...