Jump to content
43oh

Modify an lcd monitor for high impedance input


Recommended Posts

Hello, I bough a couple of cheap lcd monitors (one 4.3" and one 7") to put in my car.

Both are to be fed with the same video signal, but, as I expected, I cannot simply put them in parallel since the signal degrades too much.

The obvious solution would be to use a video distribution amplifier (maybe I could adapt this simple circuit), but I thought maybe I could modify one of the monitors for high impedance input.

I traced the input path of the 4.3" monitor and it is like this (I don't know the values of what I suppose are capacitors, there's no marking on them, they're light brown smd components):

 

video_input.jpg

 

 

(MST403 is the asic that does all the processing to drive the lcd panel, I found a datasheet but there's no specification of the input impedance of the video pins and no application notes.

 

Do you think it would be enough to eliminate R1 (cut where it is connected to ground)? Keep in mind that there will be a couple meters of cable between this monitor and the other one.

I could simply try, but with my hands I will probably destroy the board, so I will do it only if I have some probability of success.

 

TIA.

Link to post
Share on other sites

Are you sure it's not just R1 that determines the input impedance? After all, R2 and R3 are in series with the (supposedly) high impedance input of the ASIC, so, in parallel with R1, their contribution should be irrelevant.

OK, C1 will put R2 in parallel to R1, but only for frequencies above the video bandwidth (otherwise the input impedance would be ~37 Ohm).

And the other monitor will still have 75 Ohm, so it would be equivalent to R1.

It's been many years since I studied these things though, so I'm probably wrong.

Link to post
Share on other sites

I asked a colleague with a steadier hand than me and a proper soldering/desoldering station to remove R1 and I can say it works perfectly with both monitors in parallel now.

In fact the modified monitor works perfectly even without the other one connected (i.e. with no 75 Ohm termination in sight).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...