Jump to content
43oh

device node for launchpad in linux


Recommended Posts

Does anybody happen to know common device node names for the UART?  I tried "/dev/serial/by-id/usb-Texas_Instruments_Texas_Instruments_MSP-FET430UIF_19FF4695F610281B-if00" but I had no luck in capturing temperature data ( I have my launchpad programmed to send a temperature reading every second.)

 

Link to post
Share on other sites

I did try /dev/ttyACM0 with no luck.

 

Here is what i got in syslog when I plugged it in:

Feb 25 21:19:58 raspberrypi kernel: [101072.035809] usb 1-1.2.1: new full-speed USB device number 10 using dwc_otg
Feb 25 21:19:58 raspberrypi kernel: [101072.159793] usb 1-1.2.1: New USB device found, idVendor=0451, idProduct=f432
Feb 25 21:19:58 raspberrypi kernel: [101072.159824] usb 1-1.2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 25 21:19:58 raspberrypi kernel: [101072.159841] usb 1-1.2.1: Product: Texas Instruments MSP-FET430UIF
Feb 25 21:19:58 raspberrypi kernel: [101072.159856] usb 1-1.2.1: Manufacturer: Texas Instruments
Feb 25 21:19:58 raspberrypi kernel: [101072.159870] usb 1-1.2.1: SerialNumber: 19FF4695F610281B
Feb 25 21:19:58 raspberrypi kernel: [101072.172929] cdc_acm 1-1.2.1:1.0: This device cannot do calls on its own. It is not a modem.
Feb 25 21:19:58 raspberrypi kernel: [101072.172960] cdc_acm 1-1.2.1:1.0: No union descriptor, testing for castrated device
Feb 25 21:19:58 raspberrypi kernel: [101072.173056] cdc_acm 1-1.2.1:1.0: ttyACM0: USB ACM deviceFeb 25 21:20:08 raspberrypi kernel: [101082.245790] hid-generic 0003:0451:F432.0003: usb_submit_urb(ctrl) failed: -1
Feb 25 21:20:08 raspberrypi kernel: [101082.245827] hid-generic 0003:0451:F432.0003: timeout initializing reports
Feb 25 21:20:08 raspberrypi kernel: [101082.249062] hid-generic 0003:0451:F432.0003: hiddev0,hidraw0: USB HID v1.01 Device [Texas Instruments Texas Instruments MSP-FET430UIF] on usb-bcm2708_usb-1.2.1/input1



Link to post
Share on other sites

I have use that patch on all my kernels. it works for me. its a good thing to have if you are doing alot of mspwork on one PC

but I dont think thats your issue

 

 

ttyACM0

  is yuur serial device for the launchpad

 

are you sure that you are transmiting serial data? are your jumpers for sw/hw set correctly, correct baude and bit settings?

have you tried other known working programs that output serial on your msp?

Link to post
Share on other sites

I have use that patch on all my kernels. it works for me. its a good thing to have if you are doing alot of mspwork on one PC

but I dont think thats your issue

 

 

  is yuur serial device for the launchpad

 

are you sure that you are transmiting serial data? are your jumpers for sw/hw set correctly, correct baude and bit settings?

have you tried other known working programs that output serial on your msp?

I should have mentioned that it works fine under Windows, so yes it is indeed transmitting serial data and thus the jumpers are set correctly.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...