Jump to content

Compiler Error: cannot open linker script file memory.x: No such file or directory

Recommended Posts

I am an Arduino user and just discovered Energia for the MSP430.  After installing Energia on my MacBook Pro (Snow Leopard 10.6.8) and following the Getting Starting steps, I loaded the Blink sketch.  Upon compiling I get this error:



....Energia.app/Contents/Resources/Java/hardware/tools/msp430/bin/../lib/gcc/msp430/4.6.3/../../../../msp430/bin/ld: cannot open linker script file memory.x: No such file or directory
collect2: ld returned 1 exit status
This must be pretty trivial, because I cannot find anything about this in this forum.  I am hoping someone can enlighten me.
Link to post
Share on other sites
  • 10 months later...

As reference for @@energia, same here:
Energia 11 was installed just one level deep ("Other Programs"). Same location worked with Energia 09 and 10.


edit: oops, only noticed now that's a revived old thread - but same error message

Link to post
Share on other sites

Hi jaegerh,


I'm having exactly the same problem with the Energia 0101E0011 (12/17/2013). Like you I'm running deep in my Documents file. For you it's a simple matter, but for me I don't even know where to change these settings to run somewhere else...


Can you tell me exactly what you did ? I can't compile even the simplest program....




Yes !!! 


I did what you said to copy directly to C:/energia and it works. Thanks again...

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...