Jump to content

[Energia Library] Nordic nRF24L01+ library

Recommended Posts

I don't know for sure if the receiver is actually working, but I do know that it is drawing a constant 14mA and the CE pin remains high. These IC's are from Mouser, which has had a problem in recent past with counterfeit parts, so new G2553's should be on order. I can try new nRF24L01's as well, but like I said, I mixed and matched different combinations of transceivers and IC's, all with the same result. I've also disconnected and reconnected the setup multiple times with the same result, so I'm fairly confident in the wiring.

I'm using a 20A power supply which has plenty of capacitance at the output, so it should be able to adequately power the nRF24L01 to transmit a couple feet for testing purposes.

"modules set on different channel or other incompatibility in way software is set up". This, I have not looked into and don't really know enough about it to check.

By the process of elimination, I have been leaning toward the SPI file being at fault. Where is a good place to find a SPI file? I can't even remember where I downloaded mine.

Link to post
Share on other sites
  • Replies 352
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi folks... So I'm a little new to Energia, but since I wrote a library for the nRF24L01+ digital transceivers for native C-based apps I figured it'd be a great idea to port this to Energia.   I'm r

Ok, so I ported the Enrf library over so that it works with both MSP430 and Stellaris.  Seems to work great.  I am watching the tx rx demo between msp430g2553 (on the RX side), and the StellarPad doin

Okie doke - https://github.com/spirilis/Enrf24   The examples are the same as the ones I posted... I'll write up the API in a wiki page soon.  Alternately, I put documentation in the Enrf24.h file f

Posted Images

When I downloaded both versions of Energia, the Tx/Rx codes would not compile until I downloaded SPI to the libraries. Of course, this is assuming my memory serves me right.

Backing up a bit, I took the exact Tx code from github, loaded it on to both of my G2553's, and hooked them up to my two nRF24L01's. Same symptoms from both of them. So, either a piece of hardware is bad on both setups, or there's something wrong with the software. My guess is the software (meaning SPI).

"SPI keeps the chip select pin high until it is ready to transmit and then pulls it low.  It then returns to high following transmission." This is exactly what happens, only it's on the MOSI pin, not CSN.

Link to post
Share on other sites
14 minutes ago, ghjkl67 said:

When I downloaded both versions of Energia, the Tx/Rx codes would not compile until I downloaded SPI to the libraries. Of course, this is assuming my memory serves me right.

I have no idea what you mean about both versions.  ... I just went to see what is offered I see a 1.6.10E18 version  of Energia are you running that?

/rant on

... man this new version of the forum is painful to use ... i just tried to quote .. and i have no idea how i eventually was able to edit after the quote ...

I used to have problems but there was an html option which is how i usually created posts ... seems to be gone ...

/rant off

I was going to post


Link to post
Share on other sites

I tried to edit my post to include a quote. Then, I just gave up and typed quotes around it! Hopefully everyone will catch my drift.

Both versions meaning Energia 17 and Energia 18. As I type, I'm extracting the Energia 17 files to see if it already had the SPI file.


Link to post
Share on other sites

$ pwd
$ ls
examples  keywords.txt    library.properties  SPI.cpp  SPI.h  utility
/edit ...
Sorry this is not the place to deal with SPI issues. You might resolve those before continuing to post in this thread about

Link to post
Share on other sites


I just tried compiling the nRF24L01 library in V18 and got the following error:

In file included from C:\Users\Frank\Documents\Energia\MSP-EXP430F5529\Enrf24_RXdemo\Enrf24_RXdemo.ino:16:0:

C:\Users\Frank\Documents\Energia\libraries\Enrf24/Enrf24.h:32:17: fatal error: SPI.h: No such file or directory

compilation terminated.

exit status 1
Error compiling for board MSP-EXP430G2553LP.


You should not have to add SPI.  Try using Energia V17 as I suggested above.  You will find it here under previous releases:  http://energia.nu/download/  Energia V18 still seems to have some bugs. I just flashed the sample code on two G2553s with nRF24L01s using Energia V17 and they are working fine.

EDIT:  I would remove the old versions of Energia before loading a new V17.

Edited by Fmilburn
Link to post
Share on other sites

Yes, I found that bug some time ago. At first, I must have tried reinstalling SPI before discovering the trick of moving it to the front of the code. Anyway, that's irrelevant, since I'm using Energia 17 now with the proper SPI file that came with it. Here is a photo with the corresponding pin wires below:

Blue: GND and VCC

Black: P2.0

Green: P2.1

Yellow: P1.5

Orange: P1.7

Brown: P1.6

Red: P2.2

47K from VCC to RST

LED is included just for the receiver.

A separate 330 ohm resistor is included to allow the power supply to drain faster.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...