Jump to content

Recommended Posts

For the last couple of days i am getting below error while uploading to launchpad : / I have tried different usb ports, tried restarting etc.didn't work.. i am using win7 x64 and upload was working very good : / Any help?


Binary sketch size: 7,906 bytes (of a 16,384 byte maximum)

tilib: MSP430_Initialize: Could not find MSP-FET430UIF on specified COM port (error = 57)

tilib: device initialization failed 
Link to post
Share on other sites

If you google "Could not find MSP-FET430UIF on specified COM port" you'll find many hits all over the TI e2e forums, with many replies from TI employees. Granted, it seems many or even all are concerning CCS, but should not be exclusive to CCS only in fixes.


For example, one fix was to disable / kill various processes that were interfering with the USB port functionality. 


EDIT: Also as grahamf72 hit on, various COM port related applications can interfere with programming the launchpad. Such as terminal apps like puTTY etc. But if you have changed anything recently on your system that you think could cause an issue, you may want to look in that direction first.


Off the top of my head one thing you could try is disabling then   re-enabling the COM port from within device manager.

Link to post
Share on other sites

sirri, another thing to consider. Whilst I was outside splitting wood, I remembered a problem I've had in the past with Windows 7 x64. If you suspend, or hibernate  then swap out USB devices between power downs. The OS sometimes Wont recognize the change and cause problems until you completely soft boot the system.


No idea if you're using hibernate or suspend, but there you have it.

Link to post
Share on other sites

thanks for the answers.. i am still experiencing the problem. however after several tries (over ten) changing usb ports, restarting energia, restarting pc.. it suddenly worked. and once it works, it is working for the whole session (many uploads are done successfuly).. strange really.

my last applications i have installed are after effects cs6 and autocad 2011 professional.and yes before those it was working more stable : /

*i don't have ccs running background.

Link to post
Share on other sites

This is one reason why personally, I dedicate a whole machine to software development. Maybe different kinds of development on the same machine, but it reduces complications that can arise from conflicting applications. Granted, I understand not everyone can do this . . .


But, if you do confirm that one of these applications is the cause you'll obviously have a choice to make. Perhaps one work around, would be to setup more than one user on the machine, and make it so the program only installs for that user only. I do not remember if adobe applications have this fine grained of a user install method or not, and I have no idea period of autodesk applications.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...