Jump to content

[Energia Library] VirtualWire 1.10 library ported to MSP430/Energia

Recommended Posts



Which file do you use for the library. Where did you downloaded it.

I remember having the same error because in one library (which one ???) some debug code containing serial.print was left.

Try to track the "TimerSerial" in the library you use and disable it...



Link to post
Share on other sites
  • 8 months later...



Some people in this post had problems compiling the VirtualWire using Energia. This happened to me too. I was using the VirtualWire 1.20 from airspayce.com. According to the release history this version should contain support for the MSP430. I don't think it is true, I was only able to compile using the version from xv4y.radioclub.asia.


I have now a different problem. I was able to compile the examples provided by the package (the transmitter and the receiver). I am using a pair of lauchpad G2553 and a MX-FS-03V as the transmitter and a the MX-05V and the receiver. The MX-V05V needs 5V to work. I am using the TP1 from the Lauchpad as the 5V VCC for the transmitter.


The problem is the MSP430 working as a receiver doesn't do anything. To clarify, it lights a steady red led and stays like that. Open the serial monitor you only see the setup coming out but no other data. I know that the transmitter and the receivers work because I've tested them in a arduino.


I tried to troubleshoot by connecting the TX pin from the MSP430 into the RX pin of the other directly (without using the MX circuits) using a common ground.


Any ideas what could be happening?


I tried to google to see VirtualWire and the MX circuits working. I got tons of examples using arduino but I haven't seen anything (with enough details) for the Lauchpad MSP 430.


Thanks in advance for the help!

Link to post
Share on other sites

Hi Mau,


Usually, mixing 5V and 3,3V parts withtout level converter is not recommended.

By example the 5V part may need to see 3,2V to consider it as HIGH, while the the 3,3V will put out a 3,1V signal at max.

The 5V part outputs putting 5V into the MSP430 inputs may also fry the latter.


It can work, I am successfully driving a 5V AD9850 with a 3,3V MSP430G2553, but you need to carefully check the "compatibility".






Link to post
Share on other sites

Hi Yan,


Point taken. I completly neglected the voltage difference. However, could you tell me why when I direct feed the output pin from one MCU into the input pin to the second controler using a common ground between the two it didn't work? In this particular case only 3.3 V apply.


Also. Do I have to use a level converter? What if I feed the receiver with 5V (from TP1 from the USB connector of the LAUchapd) and i use a voltage divider circuit for the output of the receiver into the Launchpad?


Do you think it may work?





Link to post
Share on other sites
  • 1 month later...
Hi guys, I have a problem with using VirtualWire.

I nothing receive at all.

I use XY-FST module for TX and XY-MK-5V for RX. 

Also I checked them by using digitalWrite/digitalRead on separated devices and it work OK, I see my transmitted code.

PPS I tried LaunchPadMSP430\examples\transmitter for  Tx and LaunchPadMSP430\examples\receiver for Rx.

Link to post
Share on other sites

Thank you for responding.

This is modules which I use:




Simple rx raw test, it output zeros when transmitter vw_set_ptt_inverted(false) and output 1 when transmitter vw_set_ptt_inverted(true);

void setup()
  Serial.println("setup start");
  pinMode(P2_2, INPUT);
  Serial.println("setup end");

void loop()
  for (int i=0;i<50;i++)
    uint8_t vw_rx_sample = digitalRead(P2_2);
Link to post
Share on other sites
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...