Jump to content

Energia slow to start with TI Launchpad connected, Ubuntu 12.04

Recommended Posts

  • 1 month later...



I'm seeing a very odd behavoir that Energia is very very slow to start with Launchpad connected, as soon as I pull our the USB it starts and runs correctly. When I plug it back in it responds very slowly if at all, to mouse click.


Here my log file from dmesg.


[59962.164025] usb 2-2: new full-speed USB device number 111 using ohci_hcd

[59962.408357] cdc_acm 2-2:1.0: This device cannot do calls on its own. It is not a modem.

[59962.408364] cdc_acm 2-2:1.0: No union descriptor, testing for castrated device

[59962.408394] cdc_acm 2-2:1.0: ttyACM0: USB ACM device


dmesg Seems OK...


Both version '8 and '9 same result. java version "1.7.0_09".


I've tried starting with all manner of permissions... no change.


Windows runs fine on this board, all tests I have tried.


Any ideas? Thanks!






The solution to this is: 

install java VM from Oracle, not openjdk


how to do it?



sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-java7-installer


Link to post
Share on other sites

I've run into this issue too with 12.04 and 13.04 using both OpenJDK 7 and Oracle Java 7. I couldn't convince the patch to compile for 13.04 (kernel 3.8), but will try on 12.04 tonight.


I did discover a consistent work around though.


  1. Place the TX/RX jumpers horizontally for G2533
  2. With the Launchpad uplugged, remove the TX jumper
  3. Plug in the launchpad
  4. Launch minicom (minicom -D /dev/ttyACM0 -b9600)
  5. Put the TX jumper back. If your program is sending data you should see it now.
  6. Now launch Energia.
  7. You will see an error about ttyACM0 being locked, but you will still be able to upload code.

So far I haven't had any issues doing it this way. 



Link to post
Share on other sites
  • 2 weeks later...

@@AntonOlsen did you manage to get things going under 12.04?


The kernel CDCACM stuff has changed significantly in 12.04 to the extend that the driver included in the package will no longer compile.

I am working on scripting the process by pulling the cdcacm driver matching the kernel version from kernel.org. 

I will use this thread to keep everybody posted on the process.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...