Jump to content

Standalone VCP Driver

Recommended Posts

Hi again,


The USB chip on the MSP430 Launchpad is a TUSB3410 so I did a search and found this:

http://focus.ti.com/docs/toolsw/folders ... invcp.html


I am not very knowledgeable about the legalese in the license agreement but it looks like there is no trouble as long as the driver is used with a TI chip and since the launchpad uses this chip and their own firmware no problem right? Personally I do not even need to change the PID or VID but it seems that is not that big of a deal either or am I reading this wrong?


I have not yet tested it on a fresh computer though. I did uninstall IAR studio and tried to remove that driver but it kept recognizing the launchpad afterwards. Only after deleting usbser from the windows registry was the driver not found anymore. I was able to then install the stand alone driver from the link above and it worked perfectly :D

Link to post
Share on other sites

Hi again :roll:


Okay I am wrong somewhere...


When I got my Launchpad the drivers were installed alongside IAR on my Windows XP machine. I uninstalled IAR as completely as I can but the launchpad still get's recognized as "MSP430 Application UART" in the device manager under "Ports COM & LPT" and works as a VCP. I wanted to test the new drivers I linked to above by removing the working drivers from this system and using those. I though I did that by uninstalling the device in the device manager then deleting usbser from the windows registry. After doing that if I plug the Launchpad windows won't recognize it although it still listed under "Ports COM & LPT" . I then updated the drivers pointing to the new driver's folder and they are installed and seem to work correctly on this system. Though I was on the right track but...


So just now I have tried it on a different Win XP machine that has never had IAR installed. First the Launchpad shows up as "MSP430 Application UART" but under "Other devices" and I can not install the new drivers. :oops: I am thinking their is some little file that is installed with the IDE that tells windows that it is not a "Other device" but that it is a "Ports COM & LPT". That file seems to not be removed easily once you uninstall IAR :roll:

Link to post
Share on other sites

from what i remember in XP you have to uninstall the device driver when the device is hooked up, then reinstall it with the add device manager and select your driver from the folder or point windows to look in that folder....that should work, i had to do something similar with a cheap usb device that kept coming up as other/unknown.

Link to post
Share on other sites
  • 3 weeks later...



@ jsolarski

Thanks for the suggestion but I did try that in my attempts but no matter what I do after I plug in the launchpad it is recognized and the drivers are installed. Continuing with the keys metaphor seems once you get the keys from the horse trailer you cant get rid of them very easily. :roll:


For anyone wondering:


I have discovered on a typical install of IAR Embedded Workbench Kickstart on XP the VCP drivers folder is located here:

C:\Program Files\IAR Systems\Embedded Workbench 6.0 Kickstart\430\drivers\TIUSBFET


To install the VCP driver manually you can just point the device manager installer to the eZ430-UART folder. ;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...