Jump to content
43oh

Recommended Posts

Hello,

Could someone help me troubleshoot following issue:

Following error shows up when I attempt to upload any file to my EXP430:

Sketch uses 706 bytes (1%) of program storage space. Maximum is 48128 bytes.
Global variables use 18 bytes (0%) of dynamic memory, leaving 8174 bytes for local variables. Maximum is 8192 bytes.
java.io.IOException: Cannot run program "{runtime.tools.dslite-9.2.0.1793-e1.path}/DebugServer/bin/DSLite": CreateProcess error=2, The system cannot find the file specified
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
	at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
	at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129)
	at cc.arduino.packages.uploaders.SerialUploader.runCommand(SerialUploader.java:383)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:197)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
	at processing.app.SketchController.upload(SketchController.java:732)
	at processing.app.SketchController.exportApplet(SketchController.java:703)
	at processing.app.Editor$UploadHandler.run(Editor.java:2075)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
	at java.lang.ProcessImpl.create(Native Method)
	at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
	at java.lang.ProcessImpl.start(ProcessImpl.java:137)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
	... 9 more
An error occurred while uploading the sketch

 

  • model of LaunchPad used and revision number: MSP-EXP430F5529LP Rev 1.8
  • model of the MCU used: How do I verify this?
  • model of BoosterPack used or model of the sensor or actuator or screen: n/a
  • optionally, links to the sensor or actuator or screen data sheet: n/a
  • name and version of the IDE used: Energia 1.8.11E23
  • OS the IDE is running on: Windows 10 Home 64-bit
  • whenever possible, minimal code to replicate the issue: any file upload

 

Additional details:

  • When USB is plugged in, green light comes on and COM3 & COM4 ports show up.
  • Used the following driver: LaunchPad CDC drivers zip file for Windows 32 and 64 bit from following page https://energia.nu/guide/install/windows/

 

Please let me know if I could provide any more useful information and thank you in advance for your time.

Link to post
Share on other sites

The first line in the error log says it all:

java.io.IOException: Cannot run program "{runtime.tools.dslite-9.2.0.1793-e1.path}/DebugServer/bin/DSLite": CreateProcess error=2, The system cannot find the file specified

It's not about the launchpad but your Energia/system configuration.  In short, a "file not found" error for the compiler. So, an environment/path setting?

On my system the compiler is found @ C:\ti\Energia\energia-1.8.10E23\hardware\tools\DSLite\DebugServer\bin

if you search for dslite under your Energia installation is it found?

 

 

Link to post
Share on other sites
3 hours ago, NurseBob said:

if you search for dslite under your Energia installation is it found?

It does exist now. Must have been missing before.

Thank you.

 

Resolved: I've updated my Energia MSP430 Boards from 1.0.6 to 1.0.7 version.

Process: Tools --> Board -->  Boards Manager --> Energia MSP430 Boards --> Update

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...