Jump to content

Linux problem

Recommended Posts

Decided to give Energia a try

I installed Energia on both 32 and 64 bit versions of Ubuntu 12.04 , Mimimal problems with the install ( had to rename librxtxSeriasl.so to OLDlibrxtxSerial.so in the 64 bit install to stop it complaining about wrong word length) but on trying to run the "Blink" program I get the following error :-

/home/User/energia/hardware/tools/msp430/bin/../libexec/gcc/msp430/4.6.3/cc1plus: error while loading shared libraries: libmpc.so.2: cannot open shared object file: No such file or directory


Any ideas ?

Link to post
Share on other sites

The next release of Energia is going to include an updated compiler. However, you can find it here now:


https://github.com/energia/Energia/blob ... 32.tar.bz2


You will have to download and extract that into the appropriate directory on your unpacked Energia directory.


The gcc version in that tar file has the FRAM BSL corruption patch installed. Also, it was built with the intent of using fewer external shared libraries by statically linking with some of the required system libraries. If all else fails, you can try the build script located here:


https://github.com/energia/Energia/blob ... ild-mspgcc



Link to post
Share on other sites
  • 2 weeks later...

I haven't tried Energia on Ubuntu myself, so this is more a general Ubuntu answer than being Energia specifik. Ensure that the libmpc2 package is installed. If the problem persists try setting the LD_LIBRARY_PATH environment variable to point to the location of libmpc2. To do that open a console and type "export LD_LIBRARY_PATH=/usr/lib", replacing /usr/lib with the location of the file. Next, run Energia from that same console.


That should do the trick.

Link to post
Share on other sites
I'm having the same problem. I've tried the above solutions, but I still get the same error message as in your first post. I may have done the script incorrectly. Where should I put it when executing it?


There are two options.


1.) replace the /installdir/hardware/tools/msp430 directory under Energia with your newly built tools. Where /installdir is the directory where Energia was extracted.


2.) rename or delete the /installdir/hardware/tools/msp430 and add the bin path of your newly built tools to your PATH before starting energia.



Link to post
Share on other sites
  • 4 weeks later...


The file /usr/lib/libgmp.so.3 it's broke, for to solve this problem is necesary to install this library:


sudo ln -s /usr/lib/x86_64-linux-gnu/libgmp.so.10.0.2 /usr/lib/libgmp.so.3

sudo apt-get install libgmp3c2


sudo apt-get update



that's all.

Link to post
Share on other sites

Thanks, crow1982, that's got my Energia so it will compile sketches (I'm on Ubuntu 12.04/32-bit). However, I still can't deploy to the MSP430 as I have no serial ports listed, so there seems to be something else needed from stock Ubuntu 12.04/32bit, but I don't know what - any ideas?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...