Jump to content
43oh

MSP 430 Launch Pad board rev 1.5 UART question.


Recommended Posts

I have just purchased the MSP430 Launch Pad board rev 1.5 with the '2553 chip and wanted to know is it possible to communicate with the chip using a terminal prog such as TeraTerm? Do you have to make any changes to the board that is do you have solder on the crystal or set any jumpers or do is there a USB driver that needs to be installed. I am using Windows 7 premium and have installed Code Composer Studio 5.2 and tried the blink example successfully. However the example:

 

//******************************************************************************

// MSP430G2xx3 Demo - USCI_A0, 9600 UART Echo ISR, DCO SMCLK

//

// Description: Echo a received character, RX ISR used. Normal mode is LPM0.

// USCI_A0 RX interrupt triggers TX Echo.

// Baud rate divider with 1MHz = 1MHz/9600 = ~104.2

// ACLK = n/a, MCLK = SMCLK = CALxxx_1MHZ = 1MHz

//

// MSP430G2xx3

// -----------------

// /|\| XIN|-

// | | |

// --|RST XOUT|-

// | |

// | P1.2/UCA0TXD|------------>

// | | 9600 - 8N1

// | P1.1/UCA0RXD|<------------

//

// D. Dang

// Texas Instruments Inc.

// February 2011

// Built with CCS Version 4.2.0 and IAR Embedded Workbench Version: 5.10

//******************************************************************************

#include "msp430g2553.h"

 

void main(void)

{

WDTCTL = WDTPW + WDTHOLD; // Stop WDT

BCSCTL1 = CALBC1_1MHZ; // Set DCO

DCOCTL = CALDCO_1MHZ;

P1SEL = BIT1 + BIT2 ; // P1.1 = RXD, P1.2=TXD

P1SEL2 = BIT1 + BIT2 ; // P1.1 = RXD, P1.2=TXD

UCA0CTL1 |= UCSSEL_2; // SMCLK

UCA0BR0 = 104; // 1MHz 9600

UCA0BR1 = 0; // 1MHz 9600

UCA0MCTL = UCBRS0; // Modulation UCBRSx = 1

UCA0CTL1 &= ~UCSWRST; // **Initialize USCI state machine**

IE2 |= UCA0RXIE; // Enable USCI_A0 RX interrupt

 

__bis_SR_register(LPM0_bits + GIE); // Enter LPM0, interrupts enabled

}

 

// Echo back RXed character, confirm TX buffer is ready first

#pragma vector=USCIAB0RX_VECTOR

__interrupt void USCI0RX_ISR(void)

{

while (!(IFG2&UCA0TXIFG)); // USCI_A0 TX buffer ready?

UCA0TXBUF = UCA0RXBUF; // TX -> RXed character

}

------------------------------------------------------------------------------------------------------------------

Fails to echo back the character.

 

Any Ideas?

Black_13

Link to post
Share on other sites
I think at least one of my rev 1.5 boards came with the jumpers configured for the original LP target chips which put TX and RX on different pins than are used for the 2553. For USCI UART on the 2553, the TX/RX jumpers need to be horizontal rather than across the msp430/emulation sides of the board.

 

 

+1 to this. I was having the same issue and it was driving me crazy. I finally switched the jumpers to horizontal and it worked!

 

The current commit level in my github repo https://github.com/garyamort/IOIOExtension is based off that example. I made a few changes:

If the character is not U, I echo it back so I know it is getting there.

If the character is U, then I send "Hello World\n".

 

I used RealTerm instead of Putty. http://realterm.sourceforge.net/ Mainly because I discovered that Putty has really odd serial port handling - it won't CLOSE the port until you close all open copies of Putty - and since I typically have 3-4 outgoing SSH settings, closing all of them is a pain. RealTerm alternatively is easy to connect and does just what I need.

 

I'll add a tag to my current commit on Github this weekend so you can reference it later if you want to as I'll be junking that code shortly to replace it with the code I ACTUALLY want. :-)

 

The main difference between my code and the example is I'm segmenting out the different bits of code[ideally I'd turn them into C++ classes....but that will have to wait until I have a working copy of the code and then go back to cleanup my hacks].

 

It also includes a ton of header files and stub c code you won't be interested in for defining the IOIO protocol/functions.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...