Jump to content
Sign in to follow this  
Hails

Cannot upload file (first time user)

Recommended Posts

Hello,

It's my first time using Energia and I am trying to figure out what the error is I got when I tried to upload the Blink code onto my MSP430G2553.

I followed the steps in the installation guide, activated the TI udev rules, and tried restarting the computer.

This is the error I got:

Energia: 1.8.11E23 (Linux), Board: "MSP-EXP430G2 w/ MSP430G2553"

/home/phys319/pir/energia-1.8.10E23/hardware/energia/msp430/cores/msp430/atof.c: In function 'atof':
/home/phys319/pir/energia-1.8.10E23/hardware/energia/msp430/cores/msp430/atof.c:71:9: warning: floating constant exceeds range of 'double' [-Woverflow]
Sketch uses 810 bytes (4%) of program storage space. Maximum is 16384 bytes.
Global variables use 20 bytes (3%) of dynamic memory, leaving 492 bytes for local variables. Maximum is 512 bytes.
MSPDebug version 0.24 - debugging tool for MSP430 MCUs
Copyright (C) 2009-2016 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Chip info database from MSP430.dll v3.3.1.4 Copyright (C) 2013 TI, Inc.

Trying to open interface 1 on 002
rf2500: warning: can't detach kernel driver: No data available
Initializing FET...
FET protocol version is 30394216
Set Vcc: 3000 mV
Configured for Spy-Bi-Wire
Sending reset...
Device ID: 0x2553
  Code start address: 0xc000
  Code size         : 16384 byte = 16 kb
  RAM  start address: 0x200
  RAM  end   address: 0x3ff
  RAM  size         : 512 byte = 0 kb
Device: MSP430G2xx3
Number of breakpoints: 2
fet: FET returned NAK
warning: device does not support power profiling
Chip ID data:
  ver_id:         5325
  ver_sub_id:     0000
  revision:       00
  fab:            60
  self:           0000
  config:         00
Device: MSP430G2xx3
prog: '/tmp/arduino_build_663674/Blink.ino.hex': No such file or directory
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

 

Does anyone have a solution to this? Please let me know and thanks!

Share this post


Link to post
Share on other sites

Pretty sure this is a bug as I have the same issue.

When I go into /tmp/arduino_build_xxx/ the Blink.ino.hex file is there.  If I manually run msdebug I can upload the hex file to the launchpad.

When I download the previous version of energia, this issue goes away.  So pretty sure the problem is in the 1.8.10E23 release only.

-will

 

Share this post


Link to post
Share on other sites

I am having the same issue..

....ino.hex': No such file or directory"

Dies that mean that Energia 1.8.11E23 is a dud??

Is there a workaround anyone please?????

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...