Jump to content
Sign in to follow this  
pillum

Controlling TLC5940 with MSP430G2553 doesn't work

Recommended Posts

Do I need to update DC register before updating GS register? Also, do I need the first cycle flag when not updating it?
No, unless you have changed DC values in EEPROM. Which flag are you referring to? With VPRG and DCPRG grounded, all you need to do is send GS data. You can read status register to see if everything is OK.

Share this post


Link to post
Share on other sites

I am guessing you are referring to SCLK #193. According to spec sheet, you need it only once after DC cycle. However, not all charts support this statement. There seems to be discrepancy (figure 11 & 13 show this extra pulse after each GS cycle.)

I am not changing DC and I don't have those extra pulses and everything seems to be working fine.

 

UPDATE

I just came across slvc106 and now I know which chart and flag you are talking about.

Share this post


Link to post
Share on other sites

Hmmm, can I use GND as Low?

 

VPRG can be either GND or VCC but DCPRG can be either L or H..is there any difference?

Because I really dont know whats not working again, all the signals and connections are checked and are all right

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×