Jump to content
markatlnk

mspdebug fails on OS X Catalina

Recommended Posts

I have two macBook pros that I run Energia on. One is a maxed out machine from 1 year ago the other is from last December.  Both are updated to the latest version of Catalina. Here is the problem, when it runs on the older mac it is just fine and programs the device as expected. On the new machine, it used to work before the latest update (10.15.3) but now it says 

 

/Applications/Energia.app/Contents/Java/hardware/tools/mspdebug/mspdebug -n rf2500 --force-reset "prog x.a43"
MSPDebug version 0.24 - debugging tool for MSP430 MCUs
Copyright (C) 2009-2016 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Chip info database from MSP430.dll v3.3.1.4 Copyright (C) 2013 TI, Inc.

Trying to open interface 1 on 002
rf2500: can't claim interface: Permission denied
rf2500: failed to open RF2500 device
make: *** [prog] Error 255
 

 

Running this from the command line, I get this message.  Setting myself as root, I still get this message.

 

Why does it work on one, but not the other?

Mark

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...