Jump to content
Sign in to follow this  

Energia (Arduino for msp430)

Recommended Posts

I came across the port of the Arduino IDE for the msp430 (it is called Energia) reading another post.

Robert Wessels has made a great first stab at supporting the Arduino API for the launchpad boards. It already

works on the MacOSX and Windows platforms. Edit: [i checked in the changes to git for the linux version

[Linux isn't up to snuff yet, but I'll be helping him getting that working properly.] . It should be good to go.

If you are running linux and have a working java, msp430-gcc and mspdebug. For a limited time you can try

out an early snapshot by downloading this linux32 distribution.


http://xxxxxxx It is large (~15MB) and will be changing so it will only

available at that URL for a limited time.


Download the tar file and unpack it. To launch, just run the energia shell script. In the Energia IDE, select the Tools menu

pick one of the Launchpad boards. Set the Programmer to rf2500 and then pick your serial port. The picture below

is a snapshot of the ASCIITable example found in the Communications section. The example uses the Hardware serial

port of the msp430g2553 so make sure your TX/RX jumpers are set correctly. You can also find some msp430

specific examples. I haven't tested all the examples so don't expect everything to work. This is a very early

version of Energia.


If you are a java weenie and want to checkout the source code, you can find it up on github:






Share this post

Link to post
Share on other sites

It was a quick, easy download and recognized my msp as msp430g2452 but would not open it because of security. I've been thrashing around trying resolve this issue and would appreciate any guidance.

Share this post

Link to post
Share on other sites

Can anyone help me to get it run on Windows?

I'm using Energia 1.0 (0005a).

The Lauchpad works fine with CCSV and IAR.


- Board is set to Launchpad w/ msp430g2553

- Programmer is set to rf2500

- Serial Port is set to my Lauchpad port (COM12)

- I tried both directions for RX/TX jumpers


Compiling works, but upload does not.

There is no error message and no other message in the status window.


Do I have to flash a bootloader first, like for AVRs?


Thank you

Share this post

Link to post
Share on other sites

I haven't tried on windows so I can't say for sure. However, in the FIle/Preferences menu you can turn on verbose upload messages and it should tell you what is going on. One of the nice things about the msp430 is that it doesn't require a boot loader. The upload is handled by mspdebug or the MSP430Flasher.exe on windows. In fact, TX/RX pins are not used to upload. The TEST/RESET pins are used to upload using Spy-Bi-Wire protocol.



Share this post

Link to post
Share on other sites



thank you very much. Now I even understand a little bit how it works.

I played with MSP430Flasher from command line. Thas was very instructively but not successfull.


Then I took another LauchPad. And now it works!


The only difference between the two boards is, that the first one has the 32kHz crystal soldered.


Again, thank you for fast help.



Share this post

Link to post
Share on other sites



I use Energia build 005a under OS X with a LaunchPad and it works great.

For basic things, everything is ok.

Of course, since it is still in development, there are some bugs if you go into more complex codes. The dev team has been really responsive to my questions and that's great.


Since you can mix C/C+ and assembler code with the Wiring wrapper, my own opinion is Energia is the way to go for hobbyist who want to discover the MSP430 and write simple code faster.



Share this post

Link to post
Share on other sites

Energia, as of yesterday, has it's own Forum here on 43oh.com. The forum is at: Board index > Community > Projects > Energia


Please use the Energia forum to get help with the Energia project.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this