Jump to content
joerg430

upload error - filename syntax is incorrect

Recommended Posts

Hi guys !

I cannot upload the sketch.

An error is shown, see log attached. Although I switch the user interface to English, it is still in system language (here German).

The message ("Die Syntax ...") says: bad filename syntax.

Same thing had been asked here: https://e2e.ti.com/support/microcontrollers/msp430/f/166/t/735035?MSP-EXP430FR5739-MSP-EXP430FR5739-error-uploading-sketch

But the answer has never been verified by the original poster. I have installed these drivers 2 times. The error persists even after system reboot.

Thanks for any help. Cheers, Joerg

Sketch uses 778 bytes (37%) of program storage space. Maximum is 2048 bytes.
Global variables use 20 bytes (7%) of dynamic memory, leaving 236 bytes for local variables. Maximum is 256 bytes.
MSPDebug version 0.24 - debugging tool for MSP430 MCUs
Copyright (C) 2009-2016 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
----------------- NOTE ------------------
Modified version of mspdebug for Energia
            Do not use standalone
-----------------------------------------
Chip info database from MSP430.dll v3.3.1.4 Copyright (C) 2013 TI, Inc.

Using new (SLAC460L+) API
MSP430_GetNumberOfUsbIfs
MSP430_GetNameOfUsbIf
Found FET: HID0062:COM5
MSP430_Initialize: HID0062:COM5
Firmware version is 20409001
MSP430_VCC: 3000 mV
MSP430_OpenDevice
MSP430_GetFoundDevice
Device: F20x2_G2x2x_G2x3x (id = 0x0035)
2 breakpoints available
MSP430_EEM_Init
Chip ID data:
  ver_id:         01f2
  ver_sub_id:     0000
  revision:       30
  fab:            40
  self:           0000
  config:         02
prog: 'C:\Users\MYNAME\AppData\Local\Temp\arduino_build_465010/blink.ino.hex': Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
Device: F20x2_G2x2x_G2x3x
MSP430_Run
MSP430_Close
An error occurred while uploading the sketch

 

Share this post


Link to post
Share on other sites

I have the same problem.  Windows 8.1. 

I am just installing it for the first time today.  It seemed like it worked one time, then I updated some drivers or libraries and now I have this problem.  No matter what I try to uninstall and start from original I cannot revert back to the working version.  I have the zip file extracted to c:\ti\

Thanks for any help.

Quote

Energia: 1.8.11E23 (Windows 8.1), Board: "MSP-EXP430G2 w/ MSP430G2231"

Sketch uses 778 bytes (37%) of program storage space. Maximum is 2048 bytes.
Global variables use 20 bytes (7%) of dynamic memory, leaving 236 bytes for local variables. Maximum is 256 bytes.
MSPDebug version 0.24 - debugging tool for MSP430 MCUs
Copyright (C) 2009-2016 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
----------------- NOTE ------------------
Modified version of mspdebug for Energia
            Do not use standalone
-----------------------------------------
Chip info database from MSP430.dll v3.3.1.4 Copyright (C) 2013 TI, Inc.

Using new (SLAC460L+) API
MSP430_GetNumberOfUsbIfs
MSP430_GetNameOfUsbIf
Found FET: HID0002:COM6
MSP430_Initialize: HID0002:COM6
Firmware version is 20409001
MSP430_VCC: 3000 mV
MSP430_OpenDevice
MSP430_GetFoundDevice
Device: F20x2_G2x2x_G2x3x (id = 0x0035)
2 breakpoints available
MSP430_EEM_Init
Chip ID data:
  ver_id:         01f2
  ver_sub_id:     0000
  revision:       30
prog: 'C:\Users\PAPA~1.QUE\AppData\Local\Temp\arduino_build_892601/Blink.ino.hex': The filename, directory name, or volume label syntax is incorrect.
  fab:            40
  self:           0000
  config:         02
Device: F20x2_G2x2x_G2x3x
MSP430_Run
MSP430_Close
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
 

 

 

Share this post


Link to post
Share on other sites

Same here, upload fails with Energia 1.8.10E23 on macOS. This only impacts the MSP430s with mspdebug as uploader.

Energia generates

~/Library/Energia15/packages/energia/tools/mspdebug/0.24/mspdebug rf2500 --force-reset prog '/var/folders/wn/n7qqb8ss0k3bvpqwfcdwp_7r0000gn/T/arduino_build_280546/Blink.ino.hex’ 

and it should be

~/Library/Energia15/packages/energia/tools/mspdebug/0.24/mspdebug rf2500 --force-reset 'prog /var/folders/wn/n7qqb8ss0k3bvpqwfcdwp_7r0000gn/T/arduino_build_280546/Blink.ino.hex’

Note the ‘ before prog, not after.

I opened a ticket at https://github.com/energia/Energia/issues/1053

Share this post


Link to post
Share on other sites
  • Edit the file /Applications/Energia.app/Contents/Java/hardware/energia/msp430/platform.txt
  • Change
tools.mspdebug.upload.pattern={cmd.path} {upload.verbose} {upload.protocol} --force-reset "prog '{build.path}/{build.project_name}.hex'"

for 

tools.mspdebug.program.pattern={cmd.path} {program.verbose} {protocol} --force-reset "prog {build.path}/{build.project_name}.hex"

Note the switch between single and double quotes.

Edited by Rei Vilo
Updates with feed-back on Windows

Share this post


Link to post
Share on other sites

The only platform.txt file I have is located here: C:\ti\energia-1.8.10E23\hardware\energia\msp430

Here is a snippet from that file using wordpad.exe as the editor.  For any other novices, don't use notepad (the default windows editor).

Quote

# mspdebug
tools.mspdebug.upload.params.verbose=
tools.mspdebug.upload.params.quiet=
tools.mspdebug.path={runtime.tools.mspdebug.path}
tools.mspdebug.cmd.path={path}/mspdebug
tools.mspdebug.upload.pattern={cmd.path} {upload.verbose} {upload.protocol} --force-reset "prog '{build.path}/{build.project_name}.hex'"

tools.mspdebug.program.params.verbose=
tools.mspdebug.program.params.quiet=
tools.mspdebug.program.params.noverify=
tools.mspdebug.program.pattern={cmd.path} {program.verbose} {protocol} --force-reset "prog '{build.path}/{build.project_name}.hex'"
 

I removed the two single quote from the two lines indicated and now it works great!

Quote

--force-reset "prog '{build.path}/{build.project_name}.hex'"

is now (2 instances):

Quote

 --force-reset "prog {build.path}/{build.project_name}.hex"

 

Share this post


Link to post
Share on other sites

Yes,  this is the right file

(- as the energia-1.8.10E23 did not got a update on the MSP430 tool chain - then it would be in
c:\Users\USERNAME\AppData\Local\Energia15\packages\energia\hardware\msp430
- just for completeness)

Yes, update both lines

 

Share this post


Link to post
Share on other sites

Thanks for this information.

New user - fresh build - first attempt - upload failed - thank goodness for a help forum!

Pity there is no reference to this in any of the online support or help fiules (or better yet, a correction to the installation files).

Anyway, glad to get things going now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...