Jump to content

Problem with sensing external charger input

Recommended Posts

I have made few different board revisions, tried MSP430G2231, G2352..but problems still persist! Here is the design described:


Battery powered 2 cells of 3.2V in series, total voltage about 6.4 volts, with a 3.3V regulator for the MSP VCC.tu

MSP430 controls PWM controlled halogen light, and charging of the batteries, there are ADC inputs for total bat voltage, voltage between cells and a potentiometer voltage for pwm control and a push button for turning the devide on.


The batteries are charged by external 8V AC/DC adapter, and on board is regulator with enable pin to limit current and voltage to the maximum allowed. MSP430 get's signal from the adapter, there is a resistor divider to one of the inputs, so that the uC knows when the charger is connected.


NOW the problem is that after sending the devices to the test users, most of them developed problems, and said that they behave strangely after charging, or don't even turn on at all anymore after charging.


Now I try to prototype new board, and I just put in a simple flash led program, and tried to connect the charger plug and unplug..and everytime this happens, the flashing led program seems to reset and also debugging session ends always. If I change this input to output in the code, it doesn't reset the chip anymore but still the debugging session ends with IAR message "target execution stopped" always if I plug or unplug the charger. I don't understand, is the MSP430 too sensitive to be interfaced with external AC/DC adapter?? I have checked the voltages, there is a 590K resistor from the adapter to MSP430 input, and a 330K resistor to ground from the input, so the maxium voltage there should be is about 2.4V! I also have a 100nF cap between input and ground, to make it more stable but this seems everything but stable, unfortunately!


Help me please, what is the reason, what can be done!?

Link to post
Share on other sites
No, I don't have this cap, only the 50K resistor between reset and VCC, I will try this, thanks ))


I think ti app notes say that 47k max should be used. 50k is pretty close so it SHOULD work, but if your still having issues try decreasing it a bit down to around 20k or so.


You say you are measuring voltage of the batteries, I'm assuming these are limited to 2.4v as well (via voltage dividers). Are you sure you have set up the ADC properly with either VCC or 2.5v as the reference, if 1.5v is available and selected for reference that may be an issue.

Link to post
Share on other sites

If the reset doesn't occur anymore after adding the 1nF cap, it seems like you have an ESD/EMC problem of some sort. Without better knowledge of the rest of your circuit this is of course just speculation, but you might want to look into some kind of ESD protection circuit for the charger input if you haven't done so already.


Another (less likely) possibility would be a drop in the MSPs supply voltage. With the debugger connected, it is possible that the

Link to post
Share on other sites

I didn't have anything better here now, no TVS devices or even diodes, but I put simple resistor of 150 ohm to connect charger + and - , to make sure that there is always little bit current flowing from the charger adapter, and this seems to help alot! So I suspect that a proper TVS diode and maybe resistor also placed there, could fix this :))

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...