Jump to content
Sign in to follow this  
JMLB

timer interrupts not working

Recommended Posts

so much happened. thanks for the follow-thru posts.

 

well I feel dumb a simple reboot of my dev machine and every thing was fine

 

the uart do get hung from time to time due to buffering problems, the launchpad uses a 3410 chip and host side drivers (windows and worse, linux) may not be very mature to talk to it.

 

i suggest if u want to make your project permanent, get a ftdi or nokia data cable instead.

 

I was starting to suspect: Windows FAIL. :(

 

I need to start moving more to Linux. :)

 

actually if u are doing uart, linux is way worse.

Share this post


Link to post
Share on other sites

i am using it very well now, but it took me a lot of time make it work for me.

 

if i don't take care of the data flow from the host side, i would always get the port hung.

 

it appears that if i let the firmware start streaming immediately, like what jbml is doing, and i do not have a host side script to read them, data will buffered up (may be on the launchpad usb 3410 chip, or the acm driver) and have the port hung.

 

jbml have less problem (or no problem) when using the example as-is (firmware received one char and sends it back), but his port also got hung when he change that to have the firmware sending chars continuously.

 

u remember seeing all these posts on the stock temperature application. i think (i have not use that app) it's a similar problem, it do send continuously but at a slow rate (may be a few char per second). and i remember seeing people saying that if they run a host script continuously (reading and clearing the buffer), they can get it going.

 

and you don't see that much of posts regarding uart usage under windows. the only time i run uart under windows (to test the spectrum analyzer), i got it going on the 1st go. but it could be that i already have debug everything under linux.

 

 

the way i am using it is

. firmware never starts to send.

. host script will ask firmware to start streaming.

. host script will ask firmware to stop streaming before exiting.

. host script always enable output drain / write drain clears buffer (an acm thing, i found).

 

this way i do not need to unplug, replug and there is no issue to do flashing in between.

 

sometimes flashing may got stuck, as hid detect will poll the board here and there, i use this to turn it off

 

echo 0 > /sys/bus/hid/drivers_autoprobe

 

i am doing at most 9600 w/ it right now and it's really reliable. and i think the 9600 limit is on the launchpad usb<>ttl circuitry. w/ a nokia cable i can do way more (or course MCU need to set to 8Mhz as it's software uart).

 

but for doc, if he's new to linux at the same time, it could be frustrating.

Share this post


Link to post
Share on other sites

actually, the launchpad is the only reason I am using windows at the moment. I usually use Arch linux but from what I have read the debugger does not work on the launch pad using linux. I also wanted to jump right in to the launch pad to try it out so I downloaded the Development environment.

 

Thanks for the tip for the FTDI. I would probably go that route since I would normally pull the msp430 out of the launch pad in the final application, but I don't actually need to have it talk to my pc. I need to talk to an other micro controller using a 1 wire protocol and not any faster than 2400bps. I will eventually replace the wire with a rf transmitter.

 

The odd thing is, that I would uninstall the com port and re install it and it still would not work. after a reboot I was receiving data but I could not upload the code. I would get an error that it could not find usb1_0/usb something. I unplugged it waited a bit and plug it back (this usually works when I get can't find USB Fet but this was not the error) and no luck. I solved the problem with an other reboot.

 

stupid closed source!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×