Jump to content
43oh

Programming MSP430F5171 / MSP4305xxx with Launchpad


Recommended Posts

Hey, after getting my "wrecked" pcb's without soldermask i soldered a MSP430F5171 to the breakout and connected RST, TEST, VCC and GND to the appropriate pins of the device (Dvio, Dvcc, 2x Dvss, RST and TEST) for SBW-Programming. Datasheet says it supports SBW.

 

But i cant program it with IAR and/or CCS5.

 

Already checked the traces (no shortcuts, all have contact to the pins on the other side).

 

Checked the voltages - ~3.5V between RST+TEST and Dvss+Dvcc.

 

Also tried to directly connect it to the Emulator-part of the Launchpad, then tried to connect only GND+TEST+RST.

 

Nothing seems to work - Did i forget something or may the chip be bricked?

Link to post
Share on other sites

I think i burned the chip while soldering it :oops:

 

I tried it again with a MSP430F5172 and it worked fine with CCS5. With IAR i cannot debug - don't know why - maybe the limitations of the Kickstart-Edition ;)

 

I have some other chips here and will try it with them and report if it works ;)

 

edit: another test - after reboot and unplugging the usb-cable it also works with IAR ;)

Link to post
Share on other sites
  • 4 weeks later...

There's a limit on how much current the Launchpad can supply, since it's powering so much (TUSB3410, its crystal, the FET emulator, the LEDs, etc...). Have you tried self-powering the MSP430F5 chip? Some models have an integrated 3.3V LDO so you can hook it up to a 5V source and direct the output to the chip DVCC.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...