Jump to content

Stopped working after using a shortcut (Windows10)

Recommended Posts

I installed Energia onto my computer (in fact, on two different ones, just to be sure of myself, and got exactly the same problem on each one). Its runs FINE the first time (with an MSP432). But since it is inconvenient to open it from its unzipped folder, I created a shortcut and moved it onto the desktop (of Windows 10). Then, I clicked on that shortcut and, while the flash screen of Energia appear, ... in a flash ... it disappears in less than a second and ... nothing. Doh, not so bad, that what I thought, since I could run it again from its original place, ... that was I thought... but I was WRONG. I cannot run it from that place either, clicking on the exe or as administrator. Same flashing flash screen and next, nothing. Maybe a short flash of a command window (which shows itself only for a flash), but nothing. I suspect that trying to run it with the shortcut "destroyed" some useful initialisation. So I tried to re-unzip again the folder, but no, still the flashing flash screen and then, nothing. 
Any suggestions?
I did it on two computers, exactly the same problem on both.

If I run energia_debug from the command window, I get an error: Incorrect IDE installation folder: Your copy of the IDE is installed in a subfolder of your sketchbook. Please move the IDE to another folder. 
I did, no joy.

Edited by vanderghast
Additionnal info.
Link to post
Share on other sites

I got the same anti-virus (McAfee) on both computers, indeed, but that sounds unlikely due to the fact that it worked without any problem BEFORE that I created the shortcut, and that I don't get any message of any kind (while there is such a message when a software is blocked by McFee or by Windows Defender... in general).

Update:  Same behavior (flashing flash screen then nothing) when I disable the Real-Time Scanning from McAfee.


Edited by vanderghast
Update info.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...