Jump to content
dongwon900

java.io.IOException: Cannot run program "___REMOVE___/DebugServer/bin/DSLite": error=2, No such file or directory

Recommended Posts

Hello, I'm trying to get some code to upload to my MSP-EXP430F5529LP board.

Following this forum post (I'm on Mac OS Catalina), I installed a pre-release version of Energia, and I get this error:

Energia: 1.8.10E22 (Mac OS X), Board: "MSP-EXP430F5529LP"

Sketch uses 706 bytes (1%) of program storage space. Maximum is 48128 bytes.
Global variables use 18 bytes (0%) of dynamic memory, leaving 8174 bytes for local variables. Maximum is 8192 bytes.
java.io.IOException: Cannot run program "___REMOVE___/DebugServer/bin/DSLite": error=2, No such file or directory
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
	at java.lang.Runtime.exec(Runtime.java:620)
	at java.lang.Runtime.exec(Runtime.java:485)
	at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:11)
	at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129)
	at cc.arduino.packages.uploaders.SerialUploader.runCommand(SerialUploader.java:383)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:197)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
	at processing.app.SketchController.upload(SketchController.java:732)
	at processing.app.SketchController.exportApplet(SketchController.java:703)
	at processing.app.Editor$UploadHandler.run(Editor.java:2075)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: error=2, No such file or directory
	at java.lang.UNIXProcess.forkAndExec(Native Method)
	at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
	at java.lang.ProcessImpl.start(ProcessImpl.java:134)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
	... 11 more
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

What could be the issue? It seems like the directory that the program is trying to use is incorrect. (Maybe ___REMOVE___ is not supposed to be there or something?)

Thanks in advance!

Share this post


Link to post
Share on other sites

I'm running into the same error with Catalina on a 2019 iMac.  I'm using the early release 1.8.10E22 version of Energia.  The board is a MSP-EXP430G2ET.

Using board 'MSP-EXP430G2ET2553LP' from platform in folder: /Applications/Energia.app/Contents/Java/hardware/energia/msp430
Using core 'msp430' from platform in folder: /Applications/Energia.app/Contents/Java/hardware/energia/msp430

Another person in a thread said that many Java files were missing, so maybe E22 is not quite ready for prime time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...