Jump to content
grandmasternoob

Programming MSP430 with Energia on Mac: No USB FET was found

Recommended Posts

Howdy,

 

I'm having trouble programming my MSP430FR2433LP with Energia on my Mac. When I try to upload the program, it gives me this error:

image.thumb.png.2bc51a1803ef0af1b709338b2bc9f034.png

MSP430: Error initializing emulator: No USB FET was found.

 

Strangely, I am able to program it with the online Code Composer Studio. I have made it blink red and green lights. Unfortunately, I'm not trying to become an embedded programmer (while that would be fun, I do not have the time) so I do not want to learn CCS, registers, and serial communications in pure C. Props to all you who can do this. I really want this to work with Energia - it will save me many hours down the road.

 

I also tried this on my Windows Parallels desktop emulation software (which works pretty damn near perfectly like a true Windows OS), but I got the same error message!

 

The board and USB cable are clearly working if I can program with CCS. So what is going on with Energia?

 

Thanks,

Another Mac-using engineer with problems

Share this post


Link to post
Share on other sites

I am having the exact same error with my board (MSP-EXP430FR2355). I am currently running the newest version of the Mac os (Catalina). I have no way of connecting to my board even though the LED's light up and the code compiles. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...