Jump to content
dave45

Problem installing energia on Linux

Recommended Posts

When installing energia on Linux Ubuntu the install runs successfully and produces a desktop icon and a menu item.

The problem is that both launchers point to  "/home/$USER/Downloads/energia-1.8.7E21/arduino" -  but the file "arduino" does not exist in the energia directory so the app will not launch.

Share this post


Link to post
Share on other sites

Try moving to a different folder than Downloads.
I've had problems with a program, I can't remember which one,
but only when I moved it away from Downloads did it work.

Share this post


Link to post
Share on other sites

Thank you for your post Frida. As you suggested, I have now tried moving the energia directory to ~/home/$USER but it gives the same result.

The icon which energia creates on the desktop is labelled as  "Arduino IDE"  and, as I say, points to an Arduino file.

I looked again at the instructions for installing Energia on Linux and saw that the command line call is  "./energia &" . When this runs it puts up anther desktop icon which I edited to point to the energia executable. This does properly load Energia.

The original Arduino IDE icon seems to be some sort of Arduino integration which is not properly integrated, so I've deleted it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×