Jump to content

Recommended Posts

I am stumbling with a simple problem and can’t seem to find a solution.

I am trying to do a reset of a CC3200 LAUNCHXL(rev4.1). I first tried doing a

Software reset, this did not work. My second attempt included an

Msp430g2 to drive the reset pin on the CC3200 low via a darlington

transistor. This also did not Work.

If I connect a jumper between the reset pin and ground on the board, it also

Produces no reset.  If I push the reset button, I get a reset.

I changed the jumper wire several times.

I tried this on three separate CC3200 LAUNCXL boards none of them reset.

Please Please Please help,


Link to post
Share on other sites

I am presuming that you have the proper ground connection for the various methods you are trying:


Connect a scope probe to the reset pin on  the header (P2,  pin 5) and push the reset button. You should see the line go from high to low


If not, the pin is not connected to the line. It should reflect the state of the button, but is listed in swru372b as an OUTPUT (tab;l 8 on page 13, and fig 8 pin map) for resetting daughterboards, and though it should be usable as an input based on the schmatic.


What I would guess is not there is the 0ohm resistor R84 that connects the header pin to the line. (see CC3200-LAUNCHXL_SCH_REV4P1-C.pdf, sheet 2, location D2 shows this)


If that isn't it, you got me. I can't see any other way for this to happen (presuming the wire is good, you have the wire connected to actual ground, etc).

Link to post
Share on other sites

Thank you for the quick response. If I connect a vm to the reset pin (p2, pin5) I see vcc 3.2v, when I push the reset button it drops to zero and does a reset.

If I read resistance between one side of the push button and ground I get 100 ohms, on the other side of the button  I read 1.7k ohms.

I have no idea how to solve this. I will probably but a new CC3200SF and see if it will work.



Link to post
Share on other sites
22 minutes ago, Oldnotdead said:

If I connect a vm to the reset pin (p2, pin5) I see vcc 3.2v, when I push the reset button it drops to zero and does a reset. 


That indicates that the 0ohm resistor is in place, as it should be.


This pretty much leads to the conclusion that either you have an issue with the jumper you are using to ground the reset pin, or there is something really, really weird. If it is something really, really weird, it will make you slap your head with a ball pein hammer when you find it.

One thing to note about the use of a jumper: the stock pin headers on most of the various launchpads I have are suitable for a board connector, but the pins are borderline for a female shell connector on a cable. It seems weird when you first experience it, but the cable terminating contacts require about 1 to 2mm  more pin length. In fact, UI need to run a new board for a CNC controller tomorrow, since I used the wrong pin headers (Always double check the components. I didn't realize I had the shorter pin version in the parts rack) and the control connectors are not fully seating, and are working loose due to vibration of the control panel. One of the reasons I still use a wire wrap tool and 30AWG Kynar wire these days.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...