Jump to content
Sign in to follow this  
Myra

Basic blink program unable to be uploaded on MSP320fr2355 on macOS 10.13.3 High Sierra

Recommended Posts

Even after downloading all required drivers, I'm unable to successfully upload this basic blink code. I went to I tried uploading with all 4 port options appearing in the option but all of them showed the same error:

Energia: 1.8.7E21 (Mac OS X), Board: "MSP-EXP430FR2355LP"

Sketch uses 998 bytes (3%) of program storage space. Maximum is 32768 bytes.
Global variables use 20 bytes (1%) of dynamic memory, leaving 1004 bytes for local variables. Maximum is 1024 bytes.
DSLite version 8.2.0.1400
Configuring Debugger (may take a few minutes on first launch)...
    Initializing Register Database...
    Initializing: MSP430
    Executing Startup Scripts: MSP430
Connecting...
error: MSP430: Error connecting to the target: Unknown device
Failed: Operation was aborted
the selected serial port Failed: Operation was aborted
 does not exist or your board is not connected

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
 

 

2050598154_ScreenShot2019-02-24at1_36_25AM.thumb.png.e06c532589b0b1858a9cbc5ea44ae2be.png

I even went on to check if the MSP430 is detected or not and it showed:

550503530_ScreenShot2019-02-24at1_43_06AM.thumb.png.1a89f312408805db3df701e29e7ec037.png

I tried a different USB cable but it didn't work out. Please help to solve this problem.

Share this post


Link to post
Share on other sites

It's the macOS 10.13 High Sierra. Lol sorry mentioned that in the title instead. So is there any legit solution to this?

Share this post


Link to post
Share on other sites

It was important to be sure, as the standard uploader DSLite doesn't work on macOS 10.14 but used to work on macOS 10.13.

macOS 10.14 has changed the way USB ports are enumerated and named.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×