Jump to content

Basic blink program unable to be uploaded on MSP320fr2355 on macOS 10.13.3 High Sierra

Recommended Posts

Even after downloading all required drivers, I'm unable to successfully upload this basic blink code. I went to I tried uploading with all 4 port options appearing in the option but all of them showed the same error:

Energia: 1.8.7E21 (Mac OS X), Board: "MSP-EXP430FR2355LP"

Sketch uses 998 bytes (3%) of program storage space. Maximum is 32768 bytes.
Global variables use 20 bytes (1%) of dynamic memory, leaving 1004 bytes for local variables. Maximum is 1024 bytes.
DSLite version
Configuring Debugger (may take a few minutes on first launch)...
    Initializing Register Database...
    Initializing: MSP430
    Executing Startup Scripts: MSP430
error: MSP430: Error connecting to the target: Unknown device
Failed: Operation was aborted
the selected serial port Failed: Operation was aborted
 does not exist or your board is not connected

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.



I even went on to check if the MSP430 is detected or not and it showed:


I tried a different USB cable but it didn't work out. Please help to solve this problem.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...