Jump to content

Various Intermittent Energia Failures On Windows 10

Recommended Posts

Has anyone else experienced something like this?

I have been using Energia on Windows for years on various LaunchPads, including 430, 432, and Stellaris (now Tiva).  The Windows 10 PCs are a Surface Pro 3, a Toshiba Satellite, and an HP Pavilion.   Over the last few months, builds and uploads fail in multiple ways unpredictably.  The Serial Monitor often doesn't work, even when the TX pin has the correct signal (verified with an oscilloscope decoder).  Often the fix is simply to click the Upload button over and over until it works.  I've changed to shorter USB cables and switched from USB 3 to USB 2.  Sometimes the problem is fixed by restarting Energia or rebooting the PC.  It never stays fixed.

I've had the same kinds of issues on older versions of Energia, but the code I'm currently developing won't compile if I go back too far.  So I'm sticking with the latest version, 1.8.7E21.

I've searched the forum for this, but haven't found anything like it.  It is possible I just don't know what to search for, so I would be grateful for pointers.  I don't want to go down the rabbit hole chasing one of these specific error messages just yet.  I suspect the problem is caused by Windows and Java updates, but I have had no problems with Arduinos (UNO, Mega2600).  

BTW, I have no problems with Energia 1.8.7E21 on an older desktop running Windows 7.


Link to post
Share on other sites
On 2/15/2019 at 4:22 PM, jfd5041 said:

I don't want to go down the rabbit hole

At the risk of doing exactly that...  I've had occasional  issues with various usb/serial peripherals on windows 10 on both my workstation and laptop, especially after MS updates.
The solutions have typically been to look at changes in MS security/privacy policies which will disable device access and then render misleading error messages (e.g. "the device is in use by another application").

Your problem description doesn't seem to neatly fit what I've seen, but it might be worth taking a look.

Link to post
Share on other sites
  • 1 year later...

More than a year later...  It worked for a while, it was working yesterday, but then suddenly, with no system updates or reboots, Energia started with the false errors like not connected, etc.  Same thing with a fresh install on another Windows 10 machine; it doesn't work for 430 or Stellaris.  So I hauled out an old MacBook and no problems!  

I'm tired of fighting with Microsoft esoterica; I'll use a Mac or Linux for developing on TI products from now on.  (I could also learn TI's own development tools but I've been seduced by the Arduino world where there is a library for every sensor on the market.)

Link to post
Share on other sites
  • 5 weeks later...

Windows 10 energia-0101E0016 avast malware bytes. Tried energia 17 as well.  TM4C1294 launchpad. Tried various stellaris serial drivers. When I try to program the launchpad on 3 different launchpads and two different pc's, it uploads and programs the launchpad one time and then after that, it freezes during upload. Never uploads again. If I disconnect the usb cable and reconnect  I get : Found ICDI device with serial: 0F00E467
ICDI version: 12245
Error receiving data -9

Some times it can't find the launchpad as all to try to upload.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...