Jump to content

cc1350 not working at 433mhz with energia

Recommended Posts

i am trying to program "cc1350 launchpad-433MHz" to receive data over rf sent by another "cc1350 launchpad-433MHz" which is connected with rf-studio.

here is my code with changes i made to set frequency on 433MHz


#include "EasyLink.h"

EasyLink_RxPacket rxPacket;
EasyLink myLink;

void setup() {
  // begin defaults to EasyLink_Phy_50kbps2gfsk

  Serial.print("testing frequency: ");

uint16_t value;
void loop() {
  // Wait / block for 2 second to receive a packet.
  // rxTimeout is in Radio time and needs to be converted from miliseconds to Radio Time
  rxPacket.rxTimeout = EasyLink_ms_To_RadioTime(2000);
  // Turn the receiver on immediately
  rxPacket.absTime = EasyLink_ms_To_RadioTime(0);

  EasyLink_Status status = myLink.receive(&rxPacket);
  if (status == EasyLink_Status_Success) {
    memcpy(&value, &rxPacket.payload, sizeof(uint16_t));
    Serial.print("Packet received with lenght ");
    Serial.print(" and value ");
  } else {

    Serial.print("Error receiving packet with status code: ");
    Serial.print(" (");


the problem is:

when i run the code and open comport following message is printed continuously:

" Error receiving packet with status code: 6 (Rx Error) "

also, when i transmit on 433MHz from one cc1350 and receive on other cc1350 which is connected to rf-studio, "Packet transmitted successfully" is printed on comport but nothing is received on rfstudio

i ran the example code on code composer studio for rf on 433MHz by changing "smartrf_setting.c/.h" file, worked fine. 

i can't figure out why it is not working with energia at 433MHz.

i have successfully communicated at 868MHz between two cc1350. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now