Jump to content
Forum sending old emails Read more... ×
fabytm

G2553 UART issues

Recommended Posts

Hey guys,

I'm having some problems with my G2553 Launchpad. For some time now, the UART functionality has not functioned. I'm now sending the character "a" through the HW UART (Jumpers are positioned correctly) and what I get on my computer is completely different. I tried this in Windows 10, W7, macOS Mojave, even through the physical P1.1 and P1.2 ports to a Raspberry Pi and the result is the same.

https://imgur.com/a/yd90MIw

I also tried receiving data from a GPS module via UART and the data I received was unusable (the length of data was as expected, but the characters were gibberish).

Has anyone had something similar happen to them?

Share this post


Link to post
Share on other sites

Couple questions:

  1. Was this always the case or did it function correctly at some point?
  2. Which version of the Energia IDE and which version of the MSP430 packages do you have installed?
  3. Can you post the Sketch you have used to send data?

Robert

Share this post


Link to post
Share on other sites

1. It happened at some point, however, I don't remember exactly when.

2. I am using the latest version of Energia for both Mac and W10. I have tried with IAR 6 on Windows 10 as well.

3. I uploaded the sketch (This one is not the one used when I tried to see the UART output in the terminal. A simple program written in C was used for that, its sole purpose is to send "a" via UART as soon as the UART module is available by polling the UCA0TXIFG flag).

 

while (!(IFG2&UCA0TXIFG));
UCA0TXBUF = 'a';

 

gps.ino

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×