Jump to content
rzndmn

Mac: No such file or directory when uploading

Recommended Posts

Hello,

Uploading a sketch on OSX 10.13.6 will not succeed.
I have replaced mspdebug with version 0.22 (was 0.24).

The *.hex file exists and is readable.

Any thoughts?

 

 

Energia: 1.8.7E20 (Mac OS X), Board: "MSP-EXP430G2 w/ MSP430G2553"

...

MSPDebug version 0.22 - debugging tool for MSP430 MCUs
...

Trying to open interface 1 on 020
Initializing FET...
FET protocol version is 30394216
Set Vcc: 3000 mV
Configured for Spy-Bi-Wire
Sending reset...
Device ID: 0x2553
  Code start address: 0xc000
  Code size         : 16384 byte = 16 kb
  RAM  start address: 0x200
  RAM  end   address: 0x3ff
  RAM  size         : 512 byte = 0 kb
Device: MSP430G2xx3
Number of breakpoints: 2
fet: FET returned NAK
warning: device does not support power profiling
Chip ID data: 25 53
prog: '/var/folders/c5/s_6mfn7x2_l2fsmqz5tz9qw40000gn/T/arduino_build_853049/sketch_oct03a.ino.hex': No such file or directory
An error occurred while uploading the sketch


 

 

 

Share this post


Link to post
Share on other sites

For anyone else, the steps to get this working are:

  1. Download and install PlatformIO (which is an extension for VS Code): https://docs.platformio.org/en/latest/ide/vscode.html#installation
  2. Rearrange your folder structure to be compatible w/ what PlatformIO expects (the readme goes into more detail).  https://www.dropbox.com/s/0twl3np2yw8q0iv/Screenshot 2018-10-11 17.31.50.png?dl=0
  3. You may also need to do a bit more work to construct a PlatformIO project file (my project already came with that, so I didn't need to do this step).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×