Jump to content
fa7357

MSP430F5529 LaunchPad with FDC1004

Recommended Posts

Hello,

I'm having troubles controling FDC1004 with MSP430F5529LaunchPad.

I found the sample codes on this forum and tried using it (connecting SDA to P3.0 and SCL to P3.1. via 10k pull up resistors to 3.3V).

It compiles and upload, but doesn't actually work- serial monitor is just blank.

could you please help to fix this?)

Thank you,

Alex

 

Share this post


Link to post
Share on other sites

You should be able to modify the code I recently posted that connects the 5529 Launchpad to the TI HDC2010.  I think you would only have to figure out the relevant registers.  There is some simple code on my github to read and display the slave serial number so I suggest starting there.  If you want to use Energia/Arduino code instead of a register-based approach, someone else will have to help.

Share this post


Link to post
Share on other sites

Best option is to post the code you're running, or attempting to run.  Without such, it's almost impossible to diagnose what could be wrong in terms of the code.

I'm sure you noted that the code you pointed to is both a different device with a different pinout.

Also, do you have a logic analyzer or an oscilloscope?  Very handy tools to see what's being sent.  Finally, some I2C setups are very sensitive to the resistor values.  Lower values (eg. 2k2) can make the signal transition cleaner, but increase power losses. And, if not an obstacle, a schematic never hurts either...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×