Jump to content

MSP430 Serial Monitor not working

Recommended Posts

Hello guys,

I just got into the world of MSP but am facing a disturbing problem since hours: The Serial Monitor stays clear no matter what I am doing.

I own a MSP430G2452IN20 Launchpad Rev 1.5, all J3-Jumpers are vertical.

I did try both USB 2.0 and USB 3.0.

I did try alternative Serial Monitors like PuTTY or the terminal in CCS 6.

I did reinstall the EZ-430 UART drivers.

I tried every COM that is listed.

The Baud rate is set to 9600 in both script and serial Monitor.

The script I tried is following:

void setup() {

void loop() {


The board core in Energia is updated to version 1.0.3 and the right board is selected.


I hope you have some more solutions, I am going to collapse soon!




Share this post

Link to post
Share on other sites

You might have one of those LaunchPads that comes out of the box configured to use software uart.

On a Rev 1.5 LaunchPad, J3's RX and TX jumpers need to be set to the horizontal position to work with Serial. Also make sure that you match the baudrate set in the Sketch in the Serial monitor. In your test Sketch, you might want to add a small delay (e.g. delay(200)) at the end of the loop to not flood the Serial monitor.

Please see the pinmap:


Share this post

Link to post
Share on other sites

Thank you for your response!

I've just seen that the core on my LaunchPad is a G2553, so i turned the J3 Jumpers horizontal as you have mentioned. I also added a delay, it still does not work.


I can you provide you some pictures and screenshot if that helps.




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now