Jump to content

Using SPI and LoRa Libraries in Energia for MSP430G2553

Recommended Posts

I get the error "'SPISettings' does not name a type" when I compile my code for LoRaWAN. The codes are working in Arduino with the libraries LoRa.h and SPI.h. I have added the image to where the error is pointing at (In LoRa Library) and the Error message as well below.

I tried changing the energia SPI library to the Arduino SPI library as well but this created more problems.

Out of all the things I tried, the most simple error I get is here when it says "Does not name a type". How can I correct that bit of code to get rid of this error.

I'm a relative beginner in Energia and not sure what to do. Appreciate any help.

Thank you🙂







Link to post
Share on other sites



Thank you, but it seems I have initialized as mentioned there. However, I'm attaching the library files here and the .ino file that I'm trying to compile on Energia. Appreciate if you can further assist me

20 minutes ago, NurseBob said:

Take a look at this link  regarding include statements in C++, it may provide some insight?



Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...