Jump to content

Recommended Posts

Hello ,

I'm using MSP430F5131 Microcontroller of TI.
I also use a MSP-FET Emulator in order to program that device.
i have written a code in Code Composer Studio (Defined the properties of CCS's project to the devices im using).
I compiled the program and no errors has found.
Then i connected the MSP-FET to the board according to the datasheet SLA138H , page 26 . (The board supplies the 3.3V so i connected it to pin 4 in the JTAG connector of the MSP-FET). I didn't connect the TEST/VPP and didnt connect the the resistor R2 330Ohms as instructed in that datasheet coz i dont need to use the fuse blow protection functionality.

My problem occurs when i try to download the program to the MSP430 device , when i hit on the downloading button an error message pops up :
"Error connecting to the target: Unknown device".

I tried to do the same in IAR Embedded Workbench (Same code , same properties) it asks me to update my firmware of the MSP-FET i click ok and it updates the firmware , but then i get the same error as i have got in the Code Composer Studio : 
"Tue May 01, 2018 11:08:46: Fatal error: Could not find device (or device not supported) Session aborted! "

It is needed to be said that when i hit on the download button the "MODE" red led on the MSP-FET flashes and then stays on after the error message has been popped.

I tried to get the 3.3V supply voltage for the downloading purposes from the MSP-FET (JTAG pin 2) and it still doesn't work and get the same error.

I also made sure that the MSP430 gets the amount of voltage its needed (3.3V from the board by a regulator).

I would like to know how i can solve this problem and download my code into the MSP430.

I have attached a wiring schematic of the board. hope it will help.

thanks in advance.

updated electrical drawing.pdf

Link to post
Share on other sites

When I've seen that error I've gone back to double-check the properties and make sure that CCS has the correct device - it seems to corrupt that data from time to time - and assert that it's got the correct device.  Next is to confirm that there is sufficent power to the device and that CCS is able to correctly sense the presence & feedback. It appears you're using the SBW FET (not the USB), which is very sensitive to whether the jumper to indicate FET-powered vs. Ext-powered is properly confifigured. I don't see that jumper in your schematic, and the FET is not forgiving if the power is external and the FET is configured as internal.

Take a look at page 21 on SLAU278AC

Link to post
Share on other sites

@omerdf, I just dealt with the same problem last night.

I had two competing pull up resistors on the Reset/Test line between my CPU board and my Support board.

The strong 1K pullup on the manual reset circuit was interfering with the programming port. 

I had to temporarily remove the R4 and C1 of the Manual Reset Control circuit and then the board would program.

Does this help?


Spy Bi-Wire Programming.png

Manual Reset Control.png



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...