Jump to content
Santoidyp0p

"The system cannot find the file specified".. again sorry

Recommended Posts

Hi,

I have a project that I can run when using the Energia IDE, and it runs well. However i was trying to us the Visual Studio IDE so that i could keep the project beside a PC app which interfaces to it via UART.
My problem is the compilation error "the system cannot find the file specified".
Im using Energia 1.6 through VMicro with the RED Lauchpad w/ msp432 EMT (48MHz) 
 

  • MSP- EXP432P401R  REV 2.1
  • VISUAL STUDIO 2017 
  • WINDOWS 10
  • vMicro
  • Energia 1.6

I have the correct com port selected, and it compiles until this point :-

"
Using library Wire version 1.0.1 in folder file:///C:/Users/McintoS/AppData/Local/Energia15/packages/energia/hardware/msp432r/5.6.1/libraries/Wire
recipe.hooks.sketch.prebuild.1.pattern
"java" "-jar" "C:\Users\McintoS\AppData\Local\Energia15\packages\energia\tools\ino2cpp\1.0.2/ino2cpp.jar" -o "C:\Users\McintoS\AppData\Local\Temp\VMBuilds\Main_msp432\energia_MSP-EXP432P401RR\Release/" -T "C:\Users\McintoS\AppData\Local\Energia15\packages\energia\tools\ino2cpp\1.0.2/templates/Variables.mk.template" -r "C:\Users\McintoS\AppData\Local\Energia15\packages\energia\tools\ino2cpp\1.0.2" -n Main_msp432.ino "C:\Energia\projects\Main_msp432" msp432:MSP_EXP432P401R"
    Process: "java" "-jar" "C:\Users\McintoS\AppData\Local\Energia15\packages\energia\tools\ino2cpp\1.0.2/ino2cpp.jar" -o "C:\Users\McintoS\AppData\Local\Temp\VMBuilds\Main_msp432\energia_MSP-EXP432P401RR\Release/" -T "C:\Users\McintoS\AppData\Local\Energia15\packages\energia\tools\ino2cpp\1.0.2/templates/Variables.mk.template" -r "C:\Users\McintoS\AppData\Local\Energia15\packages\energia\tools\ino2cpp\1.0.2" -n Main_msp432.ino "C:\Energia\projects\Main_msp432" msp432:MSP_EXP432P401R"
The system cannot find the file specified

"

 

any ideas on how to fix this would be greatly appreciated.
Thank you.

Share this post


Link to post
Share on other sites

Just to make sure, the same project compiles correctly within Energia but you are seeing the error when trying to compile it in Visual Studio with the Visual Micro extention?

From the error is seems that Visual Studio is not able to execute java. Have you inquired with the folks over at Visual Micro?

Share this post


Link to post
Share on other sites

Yes it works well in Energia. I'm in the process of asking the folks at Visual Micro, thanks for your input. 
it may be as you say, in which case the folks at visual micro may better understand how to fix the issue.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×