Jump to content

Recommended Posts

Hello All, After quite a while I have dusted off a few bits and seek to get started once again with the Launchpad (Rev. 1.4). Owing to the fact that XP is no longer supported I am using Linux Mint (Sonya). I have tried to install an old version of Energia for the 32bit version of Linux I am using but it is not happening. I realise that this may be a bit 'old hat' to some 'power users' but all I want to do is carry on with my experiments and also use some of the 'shields' that I bought way back. It is just really a restart for me but any kind of help would be most welcome. It is hard to believe that it was 2013 when I last posted. Thanks for all of the previous help I got here and in advance for any assistance I can get this time. Cheers, Tryg

Link to post
Share on other sites

dubnet, Thanks a million. I will try and get it happening over the weekend. I DO have an old XP box that I may have to press into service or try it via WINE or similar, I'm still a total newb on Linux but I'm loving it. Are there any/many Radio Amateurs on this forum do you know? Cheers, Tryg

Link to post
Share on other sites

Hi Trigger,

Go back to XP.
Microsoft has dropped XP. So what?
I am still using tree HP's on XP Pro behind an extra router / hardware firewall and Avast.
Never any problem.
Energia, and a lot of other stuff for programming embedded,  runs perfectly.
All those other operating system are just that much trouble.

Don't dump something because someone tells you it is old.
( I am 70, so... ).
I am still running some very ( even for now  ) sophisticated weather, telescope and sun light/color measuring systems based on 2553's on a PC with BASIC!
Still using the good old RS232C ports.Very fast and reliable on a dual core with XP Pro.

Greetings from The Netherlands,
Henk Siewert


Link to post
Share on other sites
  • 1 year later...

Hi Folks. After a while in the woods and still keen. I cannot get a windows machine to do the business for me and my mac has died so I am using Linux Mint all of the time. I cannot get Energia working on my machine. I tried a blink sketch but got this error message...


Energia: 1.8.7E21 (Linux), Board: "MSP-EXP430G2ET w/ MSP430G2553"

/home/trigger/Desktop/energia-1.8.7E21/hardware/energia/msp430/cores/msp430/atof.c: In function 'atof':
/home/trigger/Desktop/energia-1.8.7E21/hardware/energia/msp430/cores/msp430/atof.c:71:9: warning: floating constant exceeds range of 'double' [-Woverflow]
Sketch uses 810 bytes (4%) of program storage space. Maximum is 16384 bytes.
Global variables use 20 bytes (3%) of dynamic memory, leaving 492 bytes for local variables. Maximum is 512 bytes.
DSLite version
Configuring Debugger (may take a few minutes on first launch)...
    Initializing Register Database...
    Initializing: MSP430
error: MSP430: Error initializing emulator: No USB FET was found
Failed: MSP430: Error initializing emulator: No USB FET was found

the selected serial port
 does not exist or your board is not connected

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I still want to realise my goal of controlling things with the MSP series of mcu's, stepper and lighting are my primary goals. I have one Launchpad left, I haven't done anything with it for a while but it appears to power up. This should be simple but it driving me nuts.  Any help appreciated, so many years in. Thanks in advance. I hope I can get help. I need it. ATB, Trigger


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...