Jump to content
thunderbirds

Energia compile problem : '{build.project_path}' doesn't exist or isn't a directory

Recommended Posts

Hi, I've just started with LaunchPad MSP432 + Energia + Driver MSP432 EMT Red  version 5.6.1

LaunchPad rev 2.0, Energia ver 1.6.10E18, MacOS 10.13

I updated arduino.builder with the version from arduino.1.8.5 and that fixed the problem with the MSpanList_Insert error.

But I have a java error - ino2cpp: error: sketch directory '{build.project_path}' doesn't exist or isn't a directory

Can anyway point me to what files I need to fix to address this?

thanks

Share this post


Link to post
Share on other sites

thanks,

MacOS 10.13. I never have any spaces in path/filenames (a habit from old DOS and Unix days).

Below is the error message and all the paths / files on the command line exist.

"java" "-jar" "/Users/gjok/Library/Energia15/packages/energia/tools/ino2cpp/1.0.2/ino2cpp.jar" -o "/var/folders/_z/w518m88n2hs2clk0nc4n17_80000gn/T/build41bb0049b9729603ac52432ac8ba2562.tmp/sketch/" -T "/Users/gjok/Library/Energia15/packages/energia/tools/ino2cpp/1.0.2/templates/Variables.mk.template" -r "/Users/gjok/Library/Energia15/packages/energia/tools/ino2cpp/1.0.2" -n sketch_mar06b.ino "{build.project_path}" msp432:MSP_EXP432P401R"
ino2cpp: error: sketch directory '{build.project_path}' doesn't exist or isn't a directory.

The quotes are unbalanced, the last item should be "msp432:MSP_EXP432P401R" but maybe that's an formatting error in the output (?).

The source folder of the sketch is : /Users/gjok/Documents/Energia/sketch_mar06b, so it would seem to me that the {build.project_path} should have been expanded to /Users/gjok/Documents/Energia/sketch_mar06b.

If I run above with {build.project_path} replaced with /gjok/Documents/Energia/sketch_mar06b, then no error results.

Presumably, an upstream process in the compile chain is supposed to know about {build.project_path} but doesn't and so hasn't parsed it.

So, the question is, where is {build.project_path} meant to have been set upstream?

I don't know where.

Apologies for being a newbie.

Share this post


Link to post
Share on other sites

The issue seems to be related to the driver selected.

If I specify one of the msp430 boards (pre-installed Energie MSP430 boards Built-Ib by Energia version 1.0.1) all compiles fine:

/Applications/Energia.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware "/Applications/Energia.app/Contents/Java/hardware" -hardware "/Users/gjok/Library/Energia15/packages" -tools "/Applications/Energia.app/Contents/Java/tools-builder" -tools "/Applications/Energia.app/Contents/Java/hardware/tools/msp430" -tools "/Users/gjok/Library/Energia15/packages" -built-in-libraries "/Applications/Energia.app/Contents/Java/libraries" -libraries "/Users/gjok/Documents/Energia/libraries" -fqbn=energia:msp430:MSP-EXP430F5529LP -ide-version=10610 -build-path "/var/folders/_z/w518m88n2hs2clk0nc4n17_80000gn/T/build41bb0049b9729603ac52432ac8ba2562.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "/Users/gjok/Documents/Energia/sketch_mar06b/sketch_mar06b.ino"

 

If I specify the post-installed "Energia MSP432 EMT Red boards by Energia version 5.6.1", that's when the build.project_path issue occurs.

/Applications/Energia.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware "/Applications/Energia.app/Contents/Java/hardware" -hardware "/Users/gjok/Library/Energia15/packages" -tools "/Applications/Energia.app/Contents/Java/tools-builder" -tools "/Applications/Energia.app/Contents/Java/hardware/tools/msp430" -tools "/Users/gjok/Library/Energia15/packages" -built-in-libraries "/Applications/Energia.app/Contents/Java/libraries" -libraries "/Users/gjok/Documents/Energia/libraries" -fqbn=energia:msp432r:MSP-EXP432P401RR -ide-version=10610 -build-path "/var/folders/_z/w518m88n2hs2clk0nc4n17_80000gn/T/build41bb0049b9729603ac52432ac8ba2562.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "/Users/gjok/Documents/Energia/sketch_mar06b/sketch_mar06b.ino"

 

Share this post


Link to post
Share on other sites

I'm having the same issues as you described in the original post, with the same board driver (5.6.1) and arduino_builder (1.8.5).

What exactly do you mean when you said you're using embedXcode now? I installed it, made a new project, and tried to build it (following https://www.youtube.com/watch?v=b4lnz6ixvgU ), but the build failed at line 26, and opens up a browser window listing the boards and IDEs I dont have installed. Would I need to install everything else as well in order to get it to work, or am I missing something else?

The buildtime error says "MSP-EXP432P401R board is unknown.  Stop.", at line 283 of step1.mk

I'm very new to this, so please excuse any overly stupid questions for the time being.

Share this post


Link to post
Share on other sites

Hi Ananmore,

I probably can't help much because I do not understand the backend requirements of embedXcode.

But I'm guessing it's assuming a specific environment, so here is what I have set up:

1/ macOS 10.13.1

2/ Xcode 9.2

3/ Arduino 1.8.5 - installed in /Applications

4/ Energia 1.6.10E18 installed in /Applications

5/ Cut / paste example sketch from Energia.

6/ Select Build target, run.

7/ Select Upload target, run - watch your LEDs start blinking.

 

Hope you have some luck, the embedXcode environment is very impressive.

I was getting ready to code at the Code Composer Studio level but the Energia/Arduino Sketch framework makes development so much easier.

Share this post


Link to post
Share on other sites

Ah. It fixed itself once I installed Arduino 1.8.5. That was probably it.

 

Yeah, I need to use the MSP432 for a class, and the professor only teaches us in CCStudio, while we are free to use other IDEs if we find any that work. Once I found out Energia can be used as well, and seeing how much easier the programming looks, the choice was pretty obvious.

Share this post


Link to post
Share on other sites
2 hours ago, amanmore said:

Ah. It fixed itself once I installed Arduino 1.8.5. That was probably it.

 

Yeah, I need to use the MSP432 for a class, and the professor only teaches us in CCStudio, while we are free to use other IDEs if we find any that work. Once I found out Energia can be used as well, and seeing how much easier the programming looks, the choice was pretty obvious.

If you’re on Mac, you can try embedXcode, a template for Xcode.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×