Jump to content
Sign in to follow this  

eZ430-RF2500-SEH sample source code

Recommended Posts

The last two hours I've been trying to get a look at what makes the modules tick like they do when shipped. On ti.com I downloaded CCS4 (CCE seems to be outdated). Also, I got the eZ430-RF2500-SEH_Sensor_Monitor-v1.5 sources.

As stated in the readme.txt I opened the workbench in the install folder where I've installed the sources, but no project opens. I think I've got that i have to "import" the project. At least it seems to open the project, but I can't find any main.c or something where the program logically starts O.o

Can you help me to get that thing going? I don't get what I'm doing wrong.




Share this post

Link to post
Share on other sites

Hello leomar01, if you're starting with CCS for the first time the workspace will be fresh. Make sure you are selecting 'C:\Texas Instruments\eZ430-RF2500-SEH_Sensor_Monitor-v1.5' workspace folder. After that, Import a New Project by selecting from the top menu 'Project > Import Existing CCS Project'. If you browse to 'C:\Texas Instruments\eZ430-RF2500-SEH_Sensor_Monitor-v1.5' and press ok, it will list the proper project to import.

After that, you'll need to create new Linked Resource. This is also in that readme.txt file. From CCS's top menu 'Window > Preferences' then on the left column, 'General > Workspace > Linked Resources' create a new resource called DEV_ROOT and select the 'C:\Texas Instruments\eZ430-RF2500-SEH_Sensor_Monitor-v1.5\CCE_Source' folder. Press ok and you should be able to compile and debug.


Also, there will not be a main.c file in the project. In the project, the 'Components' folder is the files needed for SimpliciTI (the wireless stack used in the application). The 'Peer Applications' folder contains 'SEH_AP_v1.5.c' (access point) and 'SEH_ED_v1.5.c' (end device). These contain your main functions and are selected based on the active build configuration. Simply right-click on the project's folder and under 'Active Build Configuration' you can select the access point or end device.



Share this post

Link to post
Share on other sites

Hello gwdeveloper,


first, thank you very much for that comprehensive post - that's seldom these days.

With your step by step explanation it worked right away... Man, that code is complicated for a beginner like me :/


Now I want to explain what went wrong in my first attempt - maybe someone else stumbles upon this thread who might find that useful.

In the readme.txt it says code composer essentials in first place - that seems to be way outdated. Hence the following explanation may not be true for CCS4. Anyway, it says

3) |- Open the workspace

3a)|-- If the files are located at 'c:\Texas Instruments\', select

'C:\Texas Instruments\eZ430-RF2500-SEH_Sensor_Monitor-v1.3\CCE_Source\Projects\Examples\peer_applications\eZ430RF' as your workspace.

|--Skip to step 5.

Compared to your explanation this is the wrong directory. Also the "Linked Ressource" - part will be missed becaus of "Skipt to step 5.".

Anyways, in my adventure of getting it to work I also tried out this step 4. It says

4) Set up the Linked Resources

|- Navigate to "Window > Preferences... > General > Workspace > Linked Resources"

|-- Make sure that the path variable DEV_ROOT is highlighted

|-- In the Linked Resources pane, click the "Edit" button

|-- In the "Edit Variable" window, click the "Folder" button and point to your DEV_ROOT directory

|-- Click "OK" until you are back at the original CCE screen

Of course there were no "DEV_ROOT" that could have been highlighted. Ok, I'm not dumb, so I created an entry "DEV_ROOT", but the problem was this passage:

3b) Select the \Projects\Examples\peer_applications\eZ430RF" as your workspace

|-- When prompted for the workspace directory, find the 'eZ430RF' folder.

|-- This will be referred to in this documentation as your SimpliciTI root directory, or your "DEV_ROOT" directory

|-- Select the "DEV_ROOT\Projects\Examples\peer_applications\eZ430RF" directory

That resulted, of course, in the wrong directory.

Anyways, now it's working, thank you again, gwdeveloper.




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...