Jump to content
Forum sending old emails Read more... ×
Sign in to follow this  
BinaryA

Help MSP430 working with USB power but not external on Vcc pin

Recommended Posts

Hi

I wonder if anybody can give a newbie some advice.

I just started using my MSP430G2553 today. Was working great through USB and getting to grips with the basics using energia 101E0017 (I couldnt get R18 working). Then decided to disconnect the USB cable and power at 3.6V through the 3 pin header (Vcc GND, GND) was working good until I knocked the board and a cable must have shorted something, as the board will no longer power through Vcc but will when using the USB cable. Powering through the Vcc on the 3 pin header or the 10 pin header on the left side of the board I get 3.6 volts on pin1 of the chip (+ve supply of the chip) but also on pin 20 I believe the ground pin of the chip. I cant understand why this should happen with external power but not when powered by the USB.

Programs can be uploaded to the board. I've tried various sketches they all work.

I'm just getting back in to electronics so I've probably missed something obvious.

(A side note should the Vcc jumper be removed when powering externally or does that not matter.)

Any help would be gratefully appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×