Jump to content
theindianninja

MSP432P401R: MSP Board Not Working With Pervasive E-paper Display

Recommended Posts

Hey guys,

I am trying to use to use the PervasiveDisplays_Library made by Rei Vilo to generate output from my microcontroller (MSP432P401R Red) to my epaper display (4.2", ModelName: E2417ES053).

However, when I run the code, the only output I get in the serial plotter is "1. Initializing screen". When I change the line in the code that specifies some other display, like "eScreen_EPD_iTC_287_BWR" instead of "eScreen_EPD_iTC_420_BWR", then the code goes all the way. However, this does not produce a result on the screen.

 

I have tried to import this project into Code Composer Studio, but the imported code refused to compile. I have made a different forum post about that issue; the link is below.

I would appreciate any input as how to tackle this problem.

Thanks,

Yeshy

287result.PNG

420result.PNG

Share this post


Link to post
Share on other sites

The problem is due to RAM size.

The 4.2" BWR e-ink display is 400 x 300 pixels x 2 colours x 2 pages = 480,000 bits = 60,000 bytes.

Although the MSP432 features 64 KB, part of the RAM is used by RTOS and thus the remaining RAM can't afford the 60,000 bytes.

Furthermore, the library from Pervasive Displays doesn't implement the primitives for the 4.2" BWR e-ink display.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×