Jump to content

MSP432 not able to connect on Energia v18 [SOLVED!]

Recommended Posts

Hi all,

When I try to connect my MSP432 launchpad to Energia v18, it connects to the right port, but it only gives me the option to list the board as a type of MSP430. When I go to Tools>Board>Board Manager, I get to the Boards Manager where I can download different types of board packages. When I try to install the Energia MSP432 Boards, I get a red error message at the bottom of the screen that says "Error downloading http://www.energia.nu/downloads/download_core.php?file=msp432-1.0.15.tar.bz2"

I've tried connecting my board to Energia v17 and the board actually connected on that version. When I try to upload an example program like "Blink" on my board, I get an error that says "Upload Failed" with the following message below (see attached picture).

I'm stuck and am unsure of what to do to get to be able to program my MSP432 through Energia regardless of the version. Any suggestions?


Link to post
Share on other sites

Does uploading with CCS work? If CCS manages to upload but Energia fails, it may be related to the firmware version used by the built-in programmer-debugger of the LaunchPad. Normally, DSLite updates the firmware. 

Also please check the path to the Energia IDE doesn't contain any spaces. Same for the project. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...