Jump to content

Installing MSP432 broke MSP430

Recommended Posts

I've been using Energia successfully (on Mac) with several programs and the MSP430FR5969 and MSP430F5529 LaunchPad boards for a couple of weeks now.

Today I acquired an MSP432P401R LaunchPad and so installed the "Energia MSP432 boards by Energia" package from Boards Manager, version 3.8.0.

After that all my MSP430 sources compile with large numbers of errors, and I can't get them to work.

Is there some way I can undo the effect of installing the MSP432 update and get back to how things were before? I've tried downloading a fresh copy of the Energia application, and deleting the Energia15 folder in my Library folder, but I still get the errors and nothing works.


Link to post
Share on other sites

Thank you for your reply.

The sketch is here: https://github.com/technoblogy/ulisp-msp430/blob/master/ulisp.ino

There are several warnings, but the error when compiling for MSP430FR5969 is:

Lisp102:442: error: return-statement with no value, in function returning 'boolean {aka unsigned char}' [-fpermissive]

I have previously successfully uploaded and run this.

(Note that I have also recently installed CCS7.1.0 in case this might have had an effect)

Thank you,

Link to post
Share on other sites

I tried to reproduce this on my Mac but am not able to. I too have MSP432 support installed as well as CCS7.1.

Can you paste the entire output so that I have a bit more information. Make sure that you have verbose during compilation checked in the Energia preferences.

Link to post
Share on other sites
13 hours ago, johnsondavies said:

I'm really sorry for wasting your time - I've worked out what the problem is and it's entirely my fault. Everything is working fine now.

Could you tell us the issue so that others can avoid it, or recognize it when a mistake is made?

Link to post
Share on other sites

I've figured out why I got confused: I'd been testing the same source file (uLisp Zero) on ATmega boards, under the Arduino IDE, and on MSP430 boards, under the Energia IDE.

I have the Preferences set the same on both IDEs, in particular, Compiler warnings: All.

On the Arduino IDE the source compiles fine with no errors or warnings.

On Energia when you select a different board any source, even BareMinimum, compiles with about 60 warnings the first time you compile it, many of these trivial and relating to the core; for example:

<command-line>:0:12: warning: missing whitespace after the macro name [enabled by default]

Compiling the same source a second time seems to suppress these warnings, but my source file still gives some warnings related to "strict-aliasing rules", presumably due to differences between the C compilers on the two platforms. But it runs OK.

I installed the Energia MSP432 boards by Energia" package from Boards Manager to try the same source on the MSP432P401R LaunchPad, and I think the reappearance of the warnings confused me, and I falsely attributed them to the newly installed package. I should have taken more care to figure out what was going on before posting on the forum, and thanks for your tolerance!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...