Jump to content
43oh

using Wire.setModule() with a value greater than 3 will "soft-brick" the board


Recommended Posts

 

 

* LaunchPad board name and version: `EK-TM4C1294XL`

* Energia IDE version (found in Energia > About Energia menu): `1.6.10E18`

* Board package version (found in Tools > Boards > Boards Manager menu): `1.0.2`

* OS name and version: `Windows 10 Pro`

 

 

 

I am expecting the ability to use all of the i2c modules on the TM4C1294, but when I enter a Wire.setModule(n) greater than 3 the board becomes unresponsive. I can then no longer program any other sketches onto the board until I run the LM Flash Tool debug port unlock.

 

Wire.setModule(0) thru 3 do not cause this problem.

 

 

steps to reproduce the problem:

 

  Setup a program to blink an led.  Use wire.setModule(0) & wire.Begin and the program will run as expected. Change wire.setModule to 4 or higher to break it.

 

note: you'll need lm flash tool and run the debug port unlock in order to program the launchpad again after breaking it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...