Jump to content

MSP-EXP432P401R Serial output on Mac

Recommended Posts

So, Indeed YELLOW_LED controls the red LED on the board. 8^)


But I still can't get serial on my Mac to work reliably. I have set the baud to 115200 (Launchpad and Energia Terminal). I have tried Serial and Serial1. I have tried both usbmodems that show up, I do have USB 3.0, but I have no control over that.


I have also tried the macOSX screen command which turns a terminal session into a serial console. The kicker is, one time I *did* get serial output to show up using this method. I was printing to Serial and Serial1 at the time. So I modified it to do one or the other but never again got any joy.


One frustrating thing is that once I try something, I have to unplug and re-plug the USB to prevent "resource already in use" errors.


Any thoughts?

Link to post
Share on other sites

Open a Terminal window and run the command to list the available ports. 

$ ls /dev/tty.*

You'll notice the MSP432 provides two. Try the first and then the second with 

$ screen /dev/tty.usbmodem00000001 115200 
$ screen /dev/tty.usbmodem00000004 115200

The first one /dev/tty.usbmodem00000001 corresponds to Serial.


The second is used to upload the sketch, so there is no need to close the Serial console.


Now, it is always recommended to quit the Serial console, ctrl-A ctrl-K for screen, before disconnecting the board. macOS has a bug with the enumeration of the USB devices. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...